BIOL398-05/S17:Week 11

From OpenWetWare
BIOL398-05: Biomathematical Modeling

MATH 388-01: Survey of Biomathematics

Loyola Marymount University

Home       People        Brightspace        Box       Help      


This journal entry is due on Thursday, April 6 at midnight PDT (Wednesday night/Thursday morning). NOTE that the server records the time as Eastern Daylight Time (EDT). Therefore, midnight will register as 03:00.

Individual Journal Assignment

  • Store this journal entry as "username Week 11" (i.e., this is the text to place between the square brackets when you link to this page).
  • Create the following set of links. (HINT: These links should all be in your personal template that you created for the Week 1 Assignment; you should then simply invoke your template on each new journal entry.)
    • Link to your journal entry from your user page.
    • Link back from your journal entry to your user page.
    • Link to this assignment from your journal entry.
    • Don't forget to add the "BIOL398-05/S17" category to the end of your wiki page.

Homework Partners

Please meet with your partner (either face-to-face or virtually) at least once when preparing this assignment. Even though you may work together to understand the article, your journal assignment must be completed individually. It is not acceptable to do a joint assignment and copy it over to each others' journal page.

  • Lauren, Cameron
  • Nika, Conor
  • Maggie

Electronic Lab Notebook

Complete your electronic notebook that gives the details of what you did for the assignment this week. Your notebook entry should contain:

  1. The purpose: what was the scientific purpose of your investigations?
    • Note that this is different than the learning purpose.
  2. Your workflow or methods: what did you actually do? Give a step by step account.
    • There should be enough detail provided so that you or another person could re-do it based solely on your notebook.
    • You may copy protocol instructions to your page and modify them as to what you actually did, as long as you provide appropriate attribution in the acknowledgments and references section.
    • Take advantage of the electronic nature of the notebook by providing screenshots, links to web pages, etc.
  3. Your results: the answers to the questions in the protocol, plus any other results you gathered. Your results will include some or all of the following: images, plots, data, and files.
    • Note that files left on the Desktop or My Documents or Downloads folders on the Seaver 120 computers will be deleted upon restart of the computers. Files stored on the T: drive will be saved. However, it is not a good idea to trust that they will be there when you next use the computer.
    • Thus, it is a critical skill for data and computer literacy to back-up your data and files in at least two ways:
    • References to data and files should be made within the methods and results section of your notebook, listed above.
    • In addition to these inline links, create a Data and Files section of your notebook to make a list of the files generated in this exercise.
  4. A scientific conclusion: what was your main finding for today's project? Did you fulfill the purpose? Why or why not?
  5. The Acknowledgments section, see below.
  6. The References section, see below.

Acknowledgments

In this section, you need to acknowledge anyone who assisted you with your assignment, either in person, electronically, or even anonymously without their knowledge.

  1. You must acknowledge your homework partner or team members with whom you worked, giving details of the nature of the collaboration. You should include when and how you met and what content you worked on together. An appropriate statement could be (but is not limited to) the following:
    • I worked with my homework partner (give name and link name to their user page) in class. We met face-to-face one time outside of class. We texted/e-mailed/chatted online three times. We worked on the <details> portion of the assignment together.
  2. Acknowledge anyone else you worked with who was not your assigned partner. This could be Dr. Dahlquist or Dr. Fitzpatrick (for example, via office hours), the TA, other students in the class, or even other students or faculty outside of the class.
  3. If you copied wiki syntax or a particular style from another wiki page, acknowledge that here. Provide the user name of the original page, if possible, and provide a link to the page from which you copied the syntax or style.
  4. If you need to reference content (such as the methods of a protocol) also acknowledge it here and include a formal citation in your References section (see below).
  5. You must also include this statement unless otherwise noted:
    • "Except for what is noted above, this individual journal entry was completed by me and not copied from another source."
  6. Sign your Acknowledgments section with your wiki signature.

References

  1. In this section, you need to provide properly formatted citations to any content that was not entirely of your own devising. This includes, but is not limited to:
    • methods
    • data
    • facts
    • images
    • documents, including the scientific literature
  2. The references in this section should be accompanied by in text citations on your page that refer to these references.
  3. Do not include citations/references to sources that you did not use.
  4. Generally, you should include a reference to that week's assignment page.
  5. The references should be formatted according to the APA guidelines.
  6. For more detailed instructions on how to cite journal articles, books, or web pages, please see the document Guidelines for Literature Citations in a Scientific Paper that you were given on the first day of class.

Microarray Data Analysis

We will be working on the protocols in class on Thursday, March 23 and Tuesday, March 28. Whatever you do not finish in class will be homework to be completed by the Week 11 journal deadline.

Before you begin...

You will record all of the manipulations of the data in an electronic lab notebook stored on this wiki. Please see the Wiki Checklist page for more details on how to do this.

Viewing File Extensions
  • The Windows 7 operating systems defaults to hiding file extensions. To turn them back on, do the following:
    Folder Options window
    1. Go to the Start menu and select "Control Panel".
    2. In the window that appears, search for "Folder Options" in the search field in the upper right hand corner.
    3. Click on "Folder Options" in the main window.
    4. When the Folder Options window appears, click on the View tab.
    5. Uncheck the box for "Hide extensions for known file types".
    6. Click the OK button.
  • The computers in Seaver 120 are are set to erase all custom user settings and restore the defaults once they have been restarted, so you will probably have to do this many times throughout the semester when using these computers.
Set Your Browser to Prompt You for the Location to Save your Downloaded Files
  • In Mozilla Firefox, open the Options window.
    • Select the radio button that says "Always ask me where to save files".
    • You could also change the default "Save files to" location to your Desktop, so that will be the first choice when it prompts you where to save the file. (You will have to temporarily deselect the radio button to do this and then reselect it when you are done.
    • Click OK to save your changes.
  • In Google Chrome, open the Settings window.
    • Click on the link at the bottom of the page that says "Advanced Settings".
    • Check the box that says "Ask where to save each file before downloading".
    • You could also change the default Download location to your Desktop, so that will be the first choice when it prompts you where to save the file.
    • Your settings are automatically saved.


Background

This is a list of steps required to analyze DNA microarray data.

  1. Quantitate the fluorescence signal in each spot
  2. Calculate the ratio of red/green fluorescence
  3. Log2 transform the ratios
    • Steps 1-3 have been performed for you by the GenePix Pro software (which runs the microarray scanner).
  4. Normalize the ratios on each microarray slide
  5. Normalize the ratios for a set of slides in an experiment
  6. Perform statistical analysis on the ratios
  7. Compare individual genes with known data
    • Steps 6-7 are performed in Microsoft Excel
  8. Pattern finding algorithms (clustering)
  9. Map onto biological pathways
    • We will use software called STEM for the clustering and mapping
  10. Identifying regulatory transcription factors responsible for observed changes in gene expression
  11. Dynamical systems modeling of the gene regulatory network
    • The modeling will be performed in MATLAB

For the modeling project, each pair of students will analyze a Dahlquist lab microarray dataset from a particular strain of yeast.

  • Wild type: Maggie
  • Δgln3: Nika and Conor
  • Δhap4: Lauren and Cameron

You will download your assigned Excel spreadsheet from Box. You were e-mailed a link to do this before class. Because the Dahlquist Lab data is unpublished, please do not post it on this public wiki. Instead, post the file(s) back to Box, which is protected by a password.

Experimental Design

In the Excel spreadsheet, there is a worksheet labled "Master_Sheet_<strain>", where strain refers to the particular strain of yeast. In this worksheet, each row contains the data for one gene (one spot on the microarray). The first column contains the "Master Index", which numbers all of the rows sequentially in the worksheet so that we can always use it to sort the genes into the order they were in when we started. The second column (labeled "ID") contains the gene identifier from the Saccharomyces Genome Database. The third column contains the Standard Name for each of the genes. Each subsequent column contains the log2 ratio of the red/green fluorescence from each microarray hybridized in the experiment (steps 1-5 above having been performed for you already).

Each of the column headings from the data begin with the experiment name ("wt" for wild type S. cerevisiae data, "dGLN3" for the Δgln3 data, etc., and "dHAP4" for the Δhap4 data). "LogFC" stands for "Log2 Fold Change" which is the Log2 red/green ratio. The timepoints are designated as "t" followed by a number in minutes. Replicates are numbered as "-0", "-1", "-2", etc. after the timepoint.

The timepoints are t15, t30, t60 (cold shock at 13°C) and t90 and t120 (cold shock at 13°C followed by 30 or 60 minutes of recovery at 30°C).

  • Begin by recording in your wiki, the strain comparison and individual dataset that you will analyze, the filename, the number of replicates for each strain and each time point in your data.
    • NOTE: before beginning any analysis, immediately change the filename so that it contains your initials to distinguish it from other students' work.

Statistical Analysis Part 1: ANOVA

The purpose of the witin-stain ANOVA test is to determine if any genes had a gene expression change that was significantly different than zero at any timepoint.

  1. Create a new worksheet, naming it either "(STRAIN)_ANOVA" as appropriate. For example, you might call yours "wt_ANOVA" or "dHAP4_ANOVA"
  2. Copy the first three columns containing the "MasterIndex", "ID", and "Standard Name" from the "Master_Sheet" worksheet for your strain and paste it into your new worksheet. Copy the columns containing the data for your strain and paste it into your new worksheet.
  3. At the top of the first column to the right of your data, create five column headers of the form (STRAIN)_AvgLogFC_(TIME) where (STRAIN) is your strain designation and (TIME) is 15, 30, etc.
  4. In the cell below the (STRAIN)_AvgLogFC_t15 header, type =AVERAGE(
  5. Then highlight all the data in row 2 associated with (STRAIN) and t15, press the closing paren key (shift 0),and press the "enter" key.
  6. This cell now contains the average of the log fold change data from the first gene at t=15 minutes.
  7. Click on this cell and position your cursor at the bottom right corner. You should see your cursor change to a thin black plus sign (not a chubby white one). When it does, double click, and the formula will magically be copied to the entire column of 6188 other genes.
  8. Repeat steps (4) through (8) with the t30, t60, t90, and the t120 data.
  9. Now in the first empty column to the right of the (STRAIN)_AvgLogFC_t120 calculation, create the column header (STRAIN)_ss_HO.
  10. In the first cell below this header, type =SUMSQ(
  11. Highlight all the LogFC data in row 2 for your (STRAIN) (but not the AvgLogFC), press the closing paren key (shift 0),and press the "enter" key.
  12. In the next empty column to the right of (STRAIN)_ss_HO, create the column headers (STRAIN)_ss_(TIME) as in (3).
  13. Make a note of how many data points you have at each time point for your strain. For most of the strains, it will be 4, but for dHAP4 t90 or t120, it will be "3", and for the wild type it will be "4" or "5". Count carefully. Also, make a note of the total number of data points. Again, for most strains, this will be 20, but for example, dHAP4, this number will be 18, and for wt it should be 23 (double-check).
  14. In the first cell below the header (STRAIN)_ss_t15, type =SUMSQ(<range of cells for logFC_t15>)-COUNTA(<range of cells for logFC_t15>)*<AvgLogFC_t15>^2 and hit enter.
    • The COUNTA function counts the number of cells in the specified range that have data in them (i.e., does not count cells with missing values).
    • The phrase <range of cells for logFC_t15> should be replaced by the data range associated with t15.
    • The phrase <number of data points> should be replaced by the number of data points for that timepoint (either 3, 4, or 5).
    • The phrase <AvgLogFC_t15> should be replaced by the cell number in which you computed the AvgLogFC for t15, and the "^2" squares that value.
    • Upon completion of this single computation, use the Step (7) trick to copy the formula throughout the column.
  15. Repeat this computation for the t30 through t120 data points. Again, be sure to get the data for each time point, type the right number of data points, and get the average from the appropriate cell for each time point, and copy the formula to the whole column for each computation.
  16. In the first column to the right of (STRAIN)_ss_t120, create the column header (STRAIN)_SS_full.
  17. In the first row below this header, type =sum(<range of cells containing "ss" for each timepoint>) and hit enter.
  18. In the next two columns to the right, create the headers (STRAIN)_Fstat and (STRAIN)_p-value.
  19. Recall the number of data points from (13): call that total n.
  20. In the first cell of the (STRAIN)_Fstat column, type =((n-5)/5)*(<(STRAIN)_ss_HO>-<(STRAIN)_SS_full>)/<(STRAIN)_SS_full> and hit enter.
    • Don't actually type the n but instead use the number from (13). Also note that "5" is the number of timepoints and the dSWI4 strain has 4 timepoints (it is missing t15).
    • Replace the phrase (STRAIN)_ss_HO with the cell designation.
    • Replace the phrase <(STRAIN)_SS_full> with the cell designation.
    • Copy to the whole column.
  21. In the first cell below the (STRAIN)_p-value header, type =FDIST(<(STRAIN)_Fstat>,5,n-5) replacing the phrase <(STRAIN)_Fstat> with the cell designation and the "n" as in (13) with the number of data points total. (Again, note that the number of timepoints is actually "4" for the dSWI4 strain). Copy to the whole column.
  22. Before we move on to the next step, we will perform a quick sanity check to see if we did all of these computations correctly.
    • Click on cell A1 and click on the Data tab. Select the Filter icon (looks like a funnel). Little drop-down arrows should appear at the top of each column. This will enable us to filter the data according to criteria we set.
    • Click on the drop-down arrow on your (STRAIN)_p-value column. Select "Number Filters". In the window that appears, set a criterion that will filter your data so that the p value has to be less than 0.05.
    • Excel will now only display the rows that correspond to data meeting that filtering criterion. A number will appear in the lower left hand corner of the window giving you the number of rows that meet that criterion. We will check our results with each other to make sure that the computations were performed correctly.

Calculate the Bonferroni and p value Correction

  1. Now we will perform adjustments to the p value to correct for the multiple testing problem. Label the next two columns to the right with the same label, (STRAIN)_Bonferroni_p-value.
  2. Type the equation =<(STRAIN)_p-value>*6189, Upon completion of this single computation, use the Step (10) trick to copy the formula throughout the column.
  3. Replace any corrected p value that is greater than 1 by the number 1 by typing the following formula into the first cell below the second (STRAIN)_Bonferroni_p-value header: =IF(STRAIN_Bonferroni_p-value>1,1,STRAIN_Bonferroni_p-value), where "STRAIN_Bonferroni_p-value" refers to the cell in which the first Bonferroni p value computation was made. Use the Step (10) trick to copy the formula throughout the column.

Calculate the Benjamini & Hochberg p value Correction

  1. Insert a new worksheet named "(STRAIN)_ANOVA_B-H".
  2. Copy and paste the "MasterIndex", "ID", and "Standard Name" columns from your previous worksheet into the first two columns of the new worksheet.
  3. For the following, use Paste special > Paste values. Copy your unadjusted p values from your ANOVA worksheet and paste it into Column D.
  4. Select all of columns A, B, C, and D. Sort by ascending values on Column D. Click the sort button from A to Z on the toolbar, in the window that appears, sort by column D, smallest to largest.
  5. Type the header "Rank" in cell E1. We will create a series of numbers in ascending order from 1 to 6189 in this column. This is the p value rank, smallest to largest. Type "1" into cell E2 and "2" into cell E3. Select both cells E2 and E3. Double-click on the plus sign on the lower right-hand corner of your selection to fill the column with a series of numbers from 1 to 6189.
  6. Now you can calculate the Benjamini and Hochberg p value correction. Type (STRAIN)_B-H_p-value in cell F1. Type the following formula in cell F2: =(D2*6189)/E2 and press enter. Copy that equation to the entire column.
  7. Type "STRAIN_B-H_p-value" into cell G1.
  8. Type the following formula into cell G2: =IF(F2>1,1,F2) and press enter. Copy that equation to the entire column.
  9. Select columns A through G. Now sort them by your MasterIndex in Column A in ascending order.
  10. Copy column G and use Paste special > Paste values to paste it into the next column on the right of your ANOVA sheet.
  • Upload the .xlsx file that you have just created to Box. Send Dr. Dahlquist and Dr. Fitzpatrick an e-mail with the link to the file (e-mail kdahlquist or bfitzpatrick at lmu dot edu).

Sanity Check: Number of genes significantly changed

Before we move on to further analysis of the data, we want to perform a more extensive sanity check to make sure that we performed our data analysis correctly. We are going to find out the number of genes that are significantly changed at various p value cut-offs.

  • Go to your (STRAIN)_ANOVA worksheet.
  • Select row 1 (the row with your column headers) and select the menu item Data > Filter > Autofilter (The funnel icon on the Data tab). Little drop-down arrows should appear at the top of each column. This will enable us to filter the data according to criteria we set.
  • Click on the drop-down arrow for the unadjusted p value. Set a criterion that will filter your data so that the p value has to be less than 0.05.
    • How many genes have p < 0.05? and what is the percentage (out of 6189)?
    • How many genes have p < 0.01? and what is the percentage (out of 6189)?
    • How many genes have p < 0.001? and what is the percentage (out of 6189)?
    • How many genes have p < 0.0001? and what is the percentage (out of 6189)?
  • When we use a p value cut-off of p < 0.05, what we are saying is that you would have seen a gene expression change that deviates this far from zero by chance less than 5% of the time.
  • We have just performed 6189 hypothesis tests. Another way to state what we are seeing with p < 0.05 is that we would expect to see this a gene expression change for at least one of the timepoints by chance in about 5% of our tests, or 309 times. Since we have more than 309 genes that pass this cut off, we know that some genes are significantly changed. However, we don't know which ones. To apply a more stringent criterion to our p values, we performed the Bonferroni and Benjamini and Hochberg corrections to these unadjusted p values. The Bonferroni correction is very stringent. The Benjamini-Hochberg correction is less stringent. To see this relationship, filter your data to determine the following:
    • How many genes are p < 0.05 for the Bonferroni-corrected p value? and what is the percentage (out of 6189)?
    • How many genes are p < 0.05 for the Benjamini and Hochberg-corrected p value? and what is the percentage (out of 6189)?
  • In summary, the p value cut-off should not be thought of as some magical number at which data becomes "significant". Instead, it is a moveable confidence level. If we want to be very confident of our data, use a small p value cut-off. If we are OK with being less confident about a gene expression change and want to include more genes in our analysis, we can use a larger p value cut-off.
  • Comparing results with known data: the expression of the gene NSR1 (ID: YGR159C)is known to be induced by cold shock. Find NSR1 in your dataset. What is its unadjusted, Bonferroni-corrected, and B-H-corrected p values? What is its average Log fold change at each of the timepoints in the experiment? Note that the average Log fold change is what we called "STRAIN)_AvgLogFC_(TIME)" in step 3 of the ANOVA analysis.
  • We will compare the numbers we get between the wild type strain and the other strains studied, organized as a table. Use this sample PowerPoint slide to see how your table should be formatted.

Clustering and GO Term Enrichment with stem

  1. Prepare your microarray data file for loading into STEM.
    • Insert a new worksheet into your Excel workbook, and name it "(STRAIN)_stem".
    • Select all of the data from your "(STRAIN)_ANOVA" worksheet and Paste special > paste values into your "(STRAIN)_stem" worksheet.
      • Your leftmost column should have the column header "Master_Index". Rename this column to "SPOT". Column B should be named "ID". Rename this column to "Gene Symbol". Delete the column named "Standard_Name".
      • Filter the data on the B-H corrected p value to be > 0.05 (that's greater than in this case).
        • Once the data has been filtered, select all of the rows (except for your header row) and delete the rows by right-clicking and choosing "Delete Row" from the context menu. Undo the filter. This ensures that we will cluster only the genes with a "significant" change in expression and not the noise.
      • Delete all of the data columns EXCEPT for the Average Log Fold change columns for each timepoint (for example, wt_AvgLogFC_t15, etc.).
      • Rename the data columns with just the time and units (for example, 15m, 30m, etc.).
      • Save your work. Then use Save As to save this spreadsheet as Text (Tab-delimited) (*.txt). Click OK to the warnings and close your file.
        • Note that you should turn on the file extensions if you have not already done so.
  2. Now download and extract the STEM software. Click here to go to the STEM web site.
    • Click on the download link, register, and download the stem.zip file to your Desktop.
    • Unzip the file. In Seaver 120, you can right click on the file icon and select the menu item 7-zip > Extract Here.
    • This will create a folder called stem. Inside the folder, double-click on the stem.jar to launch the STEM program.
  3. Running STEM
    1. In section 1 (Expression Data Info) of the the main STEM interface window, click on the Browse... button to navigate to and select your file.
      • Click on the radio button No normalization/add 0.
      • Check the box next to Spot IDs included in the data file.
    2. In section 2 (Gene Info) of the main STEM interface window, select Saccharomyces cerevisiae (SGD), from the drop-down menu for Gene Annotation Source. Select No cross references, from the Cross Reference Source drop-down menu. Select No Gene Locations from the Gene Location Source drop-down menu.
    3. In section 3 (Options) of the main STEM interface window, make sure that the Clustering Method says "STEM Clustering Method" and do not change the defaults for Maximum Number of Model Profiles or Maximum Unit Change in Model Profiles between Time Points.
    4. In section 4 (Execute) click on the yellow Execute button to run STEM.
  4. Viewing and Saving STEM Results
    1. A new window will open called "All STEM Profiles (1)". Each box corresponds to a model expression profile. Colored profiles have a statistically significant number of genes assigned; they are arranged in order from most to least significant p value. Profiles with the same color belong to the same cluster of profiles. The number in each box is simply an ID number for the profile.
      • Click on the button that says "Interface Options...". At the bottom of the Interface Options window that appears below where it says "X-axis scale should be:", click on the radio button that says "Based on real time". Then close the Interface Options window.
      • Take a screenshot of this window (on a PC, simultaneously press the Alt and PrintScreen buttons to save the view in the active window to the clipboard) and paste it into a PowerPoint presentation to save your figures.
    2. Click on each of the SIGNIFICANT profiles (the colored ones) to open a window showing a more detailed plot containing all of the genes in that profile.
      • Take a screenshot of each of the individual profile windows and save the images in your PowerPoint presentation.
      • At the bottom of each profile window, there are two yellow buttons "Profile Gene Table" and "Profile GO Table". For each of the profiles, click on the "Profile Gene Table" button to see the list of genes belonging to the profile. In the window that appears, click on the "Save Table" button and save the file to your desktop. Make your filename descriptive of the contents, e.g. "wt_profile#_genelist.txt", where you replace the number symbol with the actual profile number.
        • Upload these files to OpenWetWare and link to them on your individual journal page. (Note that it will be easier to zip all the files together and upload them as one file).
      • For each of the significant profiles, click on the "Profile GO Table" to see the list of Gene Ontology terms belonging to the profile. In the window that appears, click on the "Save Table" button and save the file to your desktop. Make your filename descriptive of the contents, e.g. "wt_profile#_GOlist.txt", where you use "wt", "dGLN3", etc. to indicate the dataset and where you replace the number symbol with the actual profile number. At this point you have saved all of the primary data from the STEM software and it's time to interpret the results!
        • Upload these files to OpenWetWare and link to them on your individual journal page. (Note that it will be easier to zip all the files together and upload them as one file).
  5. Analyzing and Interpreting STEM Results
    1. Select one of the profiles you saved in the previous step for further intepretation of the data. I suggest that you choose one that has a pattern of up- or down-regulated genes at the cold shock timepoints. Each member of your group should choose a different profile. Answer the following:
      • Why did you select this profile? In other words, why was it interesting to you?
      • How many genes belong to this profile?
      • How many genes were expected to belong to this profile?
      • What is the p value for the enrichment of genes in this profile? Bear in mind that we just finished computing p values to determine whether each individual gene had a significant change in gene expression at each time point. This p value determines whether the number of genes that show this particular expression profile across the time points is significantly more than expected.
      • Open the GO list file you saved for this profile in Excel. This list shows all of the Gene Ontology terms that are associated with genes that fit this profile. Select the third row and then choose from the menu Data > Filter > Autofilter. Filter on the "p-value" column to show only GO terms that have a p value of < 0.05. How many GO terms are associated with this profile at p < 0.05? The GO list also has a column called "Corrected p-value". This correction is needed because the software has performed thousands of significance tests. Filter on the "Corrected p-value" column to show only GO terms that have a corrected p value of < 0.05. How many GO terms are associated with this profile with a corrected p value < 0.05?
      • Select 6 Gene Ontology terms from your filtered list (either p < 0.05 or corrected p < 0.05).
        • Each member of the group will be reporting on his or her own cluster in your presentation next week. You should take care to choose terms that are the most significant, but that are also not too redundant. For example, "RNA metabolism" and "RNA biosynthesis" are redundant with each other because they mean almost the same thing.
          • Note whether the same GO terms are showing up in multiple clusters.
        • Look up the definitions for each of the terms at http://geneontology.org. In your final presentation, you will discuss the biological interpretation of these GO terms. In other words, why does the cell react to cold shock by changing the expression of genes associated with these GO terms? Also, what does this have to do with the transcription factor being deleted (for the Δgln3 and Δswi4 groups)?
        • To easily look up the definitions, go to http://geneontology.org.
        • Copy and paste the GO ID (e.g. GO:0044848) into the search field at center top of the page called "Search GO Data".
        • In the results page, click on the button that says "Link to detailed information about <term>, in this case "biological phase"".
        • The definition will be on the next results page, e.g. here.

Summary of what you need to turn in for the individual Week 11 assignment

  1. Your individual journal page should have an electronic lab notebook recording your work for the last two weeks. This includes the purpose, detailed methods, your results, the answers to any questions posed in the protocol above, a scientific conclusion, and the acknowledgments and references sectiosn. Don't forget your paragraph which is a biological interpretation of your stem results.
  2. Upload your updated Excel spreadsheet to Box that has today's calculations in it. Use the same filename as before so that the download link that you already provided to Drs. Dahlquist and Fitzpatrick will still work.
  3. Create, upload to OpenWetWare, and link to a PowerPoint presentation that contains the p value table and the screenshots of your stem results. Each slide in the presentation should have a meaningful title that describes the main message of the slide. These slides will form the basis of your final presentation in the class.
  4. Zip together all of the tab-delimited text files that you created for and from stem and upload them to Box:
    • the file that was saved from your original spreadsheet that you used to run stem
    • each of the genelist and GOlist files for each of your significant profiles.
  5. The shared journal assignment below.

Shared Journal Assignment

  • Store your shared journal entry in the shared Class Journal Week 11 page. If this page does not exist yet, go ahead and create it (congratulations on getting in first :) )
  • Link to your journal entry from your user page.
  • Link back from the journal entry to your user page.
  • Sign your portion of the journal with the standard wiki signature shortcut (~~~~).
  • Add the "BIOL398-05/S17" category to the end of the wiki page (if someone has not already done so).

View

Now that you've done your own microarray data analysis, we will revisit the case "Deception at Duke".

Reflection

  1. What were the main issues with the data and analysis identified by Baggerly and Coombs? What best practices enumerated by DataONE were violated? Which of these did Dr. Baggerly claim were common issues?
  2. What recommendations does Dr. Baggerly recommend for reproducible research? How do these correspond to what DataONE recommends?
  3. Do you have any further reaction to this case after viewing Dr. Baggerly's talk?
  4. Go back to the methods section of the paper you presented for journal club. Do you think there is sufficient information there to reproduce their data analysis? Why or why not?