Computing/Linux/Ubuntu

From OpenWetWare

(Difference between revisions)
Jump to: navigation, search
(Installation notes)
m (Installation notes)
Line 17: Line 17:
*Troubleshooting
*Troubleshooting
**Problem: <tt>unable to acquire AGP, error "xf86_ENODEV", cannot init AGP</tt>
**Problem: <tt>unable to acquire AGP, error "xf86_ENODEV", cannot init AGP</tt>
-
**[http://www2.ati.com/drivers/linux/linux_8.12.10.html Solution from ATI]
+
**[http://www2.ati.com/drivers/linux/linux_8.14.13.html Solution from ATI]
-
:There seems to be [http://www.rage3d.com/board/archive/index.php?t-33872224.html no DRI on Intel 875P chipset], suggestion: add <tt>agp=try_unsupported</tt> kernel cmdline
+
:There seems to be [http://www.rage3d.com/board/archive/index.php?t-33872224.html no DRI on Intel 875P chipset], suggestion: add <tt>agp=try_unsupported</tt> to kernel cmdline
:[http://forums.2cpu.com/archive/index.php/t-49121.html Success story 1]: add <tt>UseInternalAgp" = "no"</tt> to XF86Config-4
:[http://forums.2cpu.com/archive/index.php/t-49121.html Success story 1]: add <tt>UseInternalAgp" = "no"</tt> to XF86Config-4
:[http://www.rage3d.com/board/showthread.php?t=33749061 Success story 2]: disable the internal AGP support of the ATI driver in <tt>/etc/X11/XF86Config-4</tt> (UseInternalAGPGART to "no") and enable the <tt>intel-agp</tt> (and agpgart) module in the kernel
:[http://www.rage3d.com/board/showthread.php?t=33749061 Success story 2]: disable the internal AGP support of the ATI driver in <tt>/etc/X11/XF86Config-4</tt> (UseInternalAGPGART to "no") and enable the <tt>intel-agp</tt> (and agpgart) module in the kernel

Revision as of 18:24, 19 July 2007

Reference

Installation notes

There seems to be no DRI on Intel 875P chipset, suggestion: add agp=try_unsupported to kernel cmdline
Success story 1: add UseInternalAgp" = "no" to XF86Config-4
Success story 2: disable the internal AGP support of the ATI driver in /etc/X11/XF86Config-4 (UseInternalAGPGART to "no") and enable the intel-agp (and agpgart) module in the kernel
  • Hitachi CML174SXW in xorg.conf:
Section "Monitor"
Identifier "CML174SXW"
HorizSync 64.0 - 80.0
VertRefresh 60.0 - 75.0
# V-freq: 75.00 Hz // h-freq: 80.42 KHz
Modeline "1280x1024" 151.83 1280 1360 1544 1888 1024 1024 1027 1072
  • Additional software repositories in /etc/apt/sources.list:
## PLF REPOSITORY (Unsupported.  May contain illegal packages.  Use at own risk.)
## Medibuntu - Ubuntu 7.04 "feisty fawn" (Acroread, Google Earth, etc)
## Please report any bug on https://launchpad.net/products/medibuntu/+bugs
deb http://medibuntu.sos-sts.com/repo/ feisty free non-free
#deb-src http://medibuntu.sos-sts.com/repo/ feisty free non-free
## CANONICAL COMMERCIAL REPOSITORY (Hosted on Canonical servers, not Ubuntu
## servers. RealPlayer10, Opera, DesktopSecure and more to come.) 
deb http://archive.canonical.com/ubuntu feisty-commercial main

Miscellaneous

Feisty Fawn 7.04 beta:

  • On the Desktop: GNOME 2.18, OpenOffice.org 2.2.0rc3, X.org 7.2
  • On the Server: Apache 2.2, PostgreSQL 8.2, PHP 5.2.1, LTSP 5.0
  • "Under the hood": GCC 4.1.2, glibc 2.5, Linux 2.6.20, Python 2.5
Personal tools