
Virtual Cell Version 4.0 Tutorial II 

Creating a FRAP binding BioModel 

Introduction 

This tutorial is a continuation of the first tutorial. It is slightly more complicated in that in now includes reactive binding sites, unlabeled and 
labeled versions and bound and unbound versions of the nuclear protein RAN. 

Following the Tutorial 

You can create your own BioModel and Application as you read through the tutorial or you may choose to load the public version of this 
model. Go to View>Private Only and make sure this option is deselected so you will be able to view the public model in the Tutorial folder. 
Load the public BioModel “Tutorial_FRAPbinding”. There are two Applications, Compartmental and FRAPbinding, and the simulation results 
are saved as Simulation1 (for Compartmental) and Frap binding (for FRAPbinding). 

Defining the biological model 

Creating and Defining Compartments 

When the software starts, you are presented with an undefined BioModel. Select the compartment once with the left mouse button, and 
then use the right mouse button to access the Properties menu. Enter "cytosol" in the Feature Name text field and press OK. 

Select the compartment tool  once and click in the cytosolic compartment. Type in "nucleus" in the Feature Name text field, and "NM" 
(Nuclear Membrane) in the Membrane Name text field; press Add Feature. 

Adding Species 

Select the species tool  and then click in the nuclear compartment once. In the Add New Species dialog, enter "r" in the Name text field. 
Press Annotate and type in "RAN” in the text field and press OK.   
Continue to use the species tool to add the following Species, using the abbreviations listed in the table. 

 

 

RAN-FITC rf 
RAN_bound rB 
Binding_sites BS 
RAN_FITC_bound rfB 
Light Laser 
 

Your model should look similar to the picture when you have added a
the species. 

ll 

actions. You may want to save the model before proceeding with the re
Go to File>Save As and enter a unique name in the text field, press 
Save. 

 

 

Defining Reactions 

Select the nuclear compartment and then use the right mouse button to access the Reactions menu. 
Arrange the species in the Reactions dialog so that each is visible.  You might want to use this image as 
a guide for organizing the reactions. 

Select the reaction icon  and then click once in the nuclear compartment. Do this three more times. 
Arrange the reaction icons as in the picture above. Select the reaction icon, one at a time, and use the 
right mouse button to access the Properties option that will open the Reaction Kinetics Editor. Click the 
rename button in each editor and give the following reaction names:RAN_binding, bleaching 1, 
bleaching 2 , and RAN_FITC_binding  



Use the line tool to connect the species to the reaction icons as in the image above. The reaction 
icon is set up such that the left side of the icons is for reactants and the right side is for products. 
You have to drag to the middle of the reaction icon with the Laser species. The laser is acting as a 
catalyst for the bleaching reactions. 
Select the RAN_binding reaction icon and use the right mouse button to access the Properties 
option. Press Rename to name the reaction. This name 
will appear when the reaction icon is selected.  Select 
Mass Action for the Kinetic Type from the selection list. 
Double click the Expression text field for 
Kf_RAN_binding, and enter ".02". Double click the 
Expression text field for Kr_RAN_binding and enter ".1". 
Close the Editor when you have finished. 
 
Open the Reaction Kinetics Editor for the bleaching 1 

reaction icon.  Select General Kinetics for the Kinetic type and enter the following flux reaction 
equation: (Vmax*rf_nucleus*Laser_nucleus*((t>10.0)&&(t<10.5))).  Vmax will appear as a 
parameter. Double click the Expression text field and type in "50.0". Press Enter to accept the 
value. This equation defines the bleaching period as .5 seconds, starting after 10 seconds. 

 
Open the Reaction Kinetics Editor for the bleaching 2 
reaction icon. Select General for the Kinetic type and enter the following Rate Equation: 
(Vmax2*rfB_nucleus*Laser_nucleus*((t>10.0)&&(t<10.5))). Vmax2 will appear as a parameter. 
Double click the Expression text field and type in "50.0". Press Enter to accept the value. This 
equation defines the bleaching period as .5 seconds, starting after 10 seconds. 
 
There are two separate bleaching reactions to account 
for bound and unbound RAN. Open the Reaction 
Kinetics Editor for the RAN_FITC_binding reaction icon. 
Select Mass Action for the Kinetic Type and enter ".02" 
for a Forward Rate, Kf, and ".1" for a Reverse Rate, Kr.  
Once all the reactions have been entered, save the 
model and proceed to Application. 
 

 

The FRAP binding Application 

Introduction 

Each model being developed requires an Application, which consists of a detailed description of the cellular geometry, Structure Mapping, 
Initial Conditions, and Reaction Mapping. The geometry represents the morphometry of a particular cell or portion of a cell. The geometry 
may be captured by various imaging modalities such as wide field, confocal, or electron microscopy. Analytic geometry may be used to 
define very regular structures or symmetric cells.  

Creating the geometry 

In this model you will initially create a Compartmental model where the BioModel is mapped to a single point. Run the simulation, and after 
you review your results create a spatial model. In the Spatial model you will map the BioModel to a defined Geometry and run another 
simulation. The results for the Compartmental model will give you an initial idea about how your model is performing. The results you get in 
the Spatial model, although they will be more accurate, should be similar to those obtained in the Compartmental model.  

I. Compartmental Geometry 

A Compartmental model represents a single point simulation based on the defined 
physiological model and the geometric assumptions, the Surface to Volume Ratio and 
Volume Fraction. Compartmental models are not spatially resolved. The compartmental 
models are solved using nonlinear ordinary differential equations. These equations are 
generally computed within seconds.  
In the Application panel of the BioModel document go to Application>New and enter 
"compartmental" for the Application name. The Application will initialize with the 
Structure Mapping panel. The compartmental model, the default model, is automatically 
mapped to a single compartment.  

 

 



II. Spatial Geometry 

In the BioModel document, go to File>New>Geometry>Analytic> 2-D. You will be 
presented with the Geometry document which contains a single subVolume viewable in the 
Geometry Editor. Press Add one more time to create an additional subVolume. The two 
subVolumes that you create will represent the extracellular and cytosolic compartments.  
Select one of the subVolumes and double click the Name text field. Type in "cytosol" and 
press Enter. Double click the Value text field and enter the following equation to define a 
circle:  ((x*x)+(y*y))<100.0 Press Enter after entering the equation.  
Double click the Name text field for the other subVolume and enter "extracellular". Press 

the Change domain button to access the 
Geometry size dialog. Enter "22" in the X and 
Y size text fields, and enter "-11" in the X and 
Y origin text fields. Press OK to accept the 
values and to close the window. 
If the circle you just defined is not visible, 

make sure to select the cytosolic volume and press Front to bring it in front of the 
extracellular volume. The Front and Back buttons set the positioning of the subVolumes. It 
is important to arrange the subVolumes in the list so they are calculated in the proper 
order. If a subVolume is hidden or unreachable, it will not be calculated. 
Save the Geometry by going to File>Save. 

Creating the Applications 

I. Compartmental Application 

Structure Mapping 

On the Structure Mapping tab, double click the SurfVol column for the nucleus. Type in ".2" for the Surface to Volume Ratio and press Enter 
to accept the value. 

Initial Conditions 

Select the Initial Conditions tab. Double click in the Initial Conditions text field for RAN and enter an 
initial concentration of 5.0. Press OK to accept the value and to dismiss the dialog. Do the same for 
RAN-FITC, enter a value of 5.0 and for Binding sites enter a value of 20.0.  
You may want to resave your model at this point and proceed to Compartmental Simulation.

II. Spatial Application 

Structure Mapping 

Return to the BioModel document, and in the Application panel, go to Application>New. 
Press View/Change Geometry. Select the geometry you just created from the Geometry 
database. The geometry will appear in the Structure Mapping tab of the Application dialog. 

Use the line tool  to map the physiology model to the geometric representation. Map 
extracellular to extracellular and cytosol to cytosol. You need to reselect the line tool each 
time you do a mapping, and you need to map from the physiology to the geometry.  

Initial Conditions 

Select the Initial Conditions tab. Double click the Initial Conditions text field for RAN 
(r_nucleus), enter 5.0 in the Expression Editor and enter 10 in the Diffusion Rate text 
field. Remember to press Set for the Diffusion Rate.  
Enter the same values, in the same manner, for RAN-FITC (rf_nucleus) as you did for 
RAN; 5.0 for an Initial Concentration and 10.0 for the Diffusion Rate. 
Select Binding_sites (BS_nucleus). Double click the Initial Conditions text field and enter 
the following equation in the Expression Editor text box: (20.0*((x>-3.0)&&(x<3.0)&&(y>-
5.0)&&(y<5.0))) 
Double click the Initial Conditions text field for the Laser. Type in the following equation 
and press OK to accept the equation: ((x>-5.0)&&(x<5.0)&&(y>-5.0)&&(y<5.0)) 

Reaction Mapping 

Leave the Reaction Mapping as the default. The reactions should all be enabled. Fast 



kinetics should not be enabled. Resave your model and proceed to Spatial Simulation. 

Running the FRAP Binding Compartmental and Spatial Simulations 

I Compartmental Simulation and Results 

Select the Simulation tab and press the New button. In the upper panel of the Simulations dialog, a 
simulation with a default name will appear. Double click the Name text field and type in a 
simulation name. You can add additional notes regarding the simulation in the Comments text field 
if you choose to do so. 
Press the Edit button to access the Parameters tab that lists all the parameters in the model and 
their corresponding values, Actual and Default. You can 
change the values and run new simulations without having 
to rebuild a new model. Double click the Actual Value text 
field for a Parameter and enter a new value. Altered values 
appear in red text. In this tutorial we will not alter any values. 
Press the Task tab to define the run conditions for the 
simulation, as listed in the table.  

Start Time: 0 
Time Step: 0.1  
End time: 30.0  
Save Interval: 1 

 

 

 

The Advanced tab has various integrators to choose from. Use all but one of the default settings 
for this example. The only change you will make is to the Maximum Time Step. Change this from 
the default of 1.0 to 0.1. 
Make sure your simulation is still selected when you press the Run button to initiate the simulation. 
Your model will automatically be resaved with the new  run conditions and the simulation will 
begin. The results are stored on the remote database server. 
Once the simulation has generated some results, the Status field will display Complete and the 
Results field will display Yes. The simulation must be selected for the Results button to be active.  
Press the Results button to open the Results dialog or wait until the simulation is complete and the 
dialog will open automatically.  
You can select how you want the graph constructed by choosing the 
parameters for the X and Y axes. The graph is interactive; put your mouse 
over the graph to see the coordinates for each data point on the curve. Press 
the right mouse button to access the Plot setting dialog for additional graphing 
options. 

 

Export Features 

Press the Export Data tab on the Simulations dialog. Results from compartmental simulations can be exported as Comma Delimited ASCII 
files which can be opened in graphing programs such as Excel. See Chapter 9 of the user guide, Exporting Simulation Results, for more 
information. 

II Spatial Simulation and Results 

Press the Simulations tab on the Application dialog and press the New button. Double click in the Name text 
field to name the simulation.  
Press the Edit button to access the Mesh and Task tabs. Select the Mesh tab, enter "51" for the X and Y 
dimensions for the Mesh Size. The Geometry Size, which was defined in the Geometry Editor, should be 
listed as (22.0, 22.0, 0).  
 
 
 

 
 
 
 
 
 



Press the Task tab to define the run conditions for the simulation, as described in the table. Press OK to 
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Make sure your simulation is still selected when you press Run to initiate the simulation. Your model 

he Results dialog. The 

hange the time interval or enter a time 

p. You may toggle between 
er 

ools to generate a Spatial Plot. 

to 

 

 

Export Features 

Press Show export controls to display the export features. Select the variable(s), time interval and 

r guide, 

accept the conditions and to close the dialog. 
Start Time: 0 
Time Step: 0.0
End Time: 30.0 
Save Interval: 10

 
 
 

will automatically be resaved with the run conditions and the simulation will begin. The results from 
the simulation are automatically stored on the remote database server. 
Once results have been generated, press the Results button to access t
simulation must be selected to activate the Results button. 
Use the scroll bar, on the left side of the Results dialog, to c
in the Time text field and press Enter. You can drag the scroll bar or select it and then use the up 
and down arrows on your keyboard to step through the time points. 
You can display your results in either a Gray or a Blue-Red color ma
auto and manual scaling. Enter values in the Min and Max text fields for manual scaling. Rememb
to press Enter to accept the value and to update the image display. 
Use the Point tool to generate a Time Plot, and the Line and Spline t
You can choose between displaying your results as a plot or viewing the data values. Press your 
right mouse button, while over the graph, 
access the Plot Settings dialog. 

 
 

data region(s) you wish to export. Files may be exported as Comma delimited ASCII files, 
QuickTime move files, GIF89a image files or Animated GIF files. See Chapter 10 of the use
Exporting Simulation Results, for more information. 
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