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1 Introduction 
The National Resource for Cell Analysis and Modeling has developed the Virtual Cell Modeling and Simulation Framework version 4.1. This unique 
software platform has been designed to model cell biological processes. This new technology associates biochemical and electrophysiological data 
describing individual reactions with experimental microscopic image data describing their subcellular locations. Cell physiological events can then be 
simulated within the empirically derived geometries, thus facilitating the direct comparison of model predictions with experiment.  

The Virtual Cell consists of a biological and mathematical framework. 
Scientists can create biological models from which the software will generate 
the mathematical code needed to run simulations. Mathematicians may opt to 
use the math framework, based on the Virtual Cell Math Language, for 
creating their own mathematical descriptions. The simulations are run over the 
internet on 84 servers with 256 GHz total cpu power and 119Gb total RAM. 
Currently the storage capacity is 11.7 Tb. 

Models can be reused, updated and published so they are available to the 
scientific community. In addition, models may also be privately shared 
amongst collaborating groups. The data from simulations is stored on the 
Virtual Cell database server and is easily exported in a variety of formats.  

Access to the Virtual Cell modeling software is available via the internet using 
a JAVA based interface. Version 4.0 of the Virtual Cell has been developed 
using the latest Java 2 SDK technology. 

1.1 Registration 
There is no charge for academic use of the Virtual Cell, however you are required to register. User registration information will aid in serving the Virtual 
Cell user community.  

 New User Registration-http://vcell.org/vcellR4/login/newuser.jsp 

1.2 System Requirements  
The following have been tested to be the appropriate system configuration for running the Virtual Cell. 

Display  

Minimum: 1024x768, 16 bit color, 17'' monitor  

Recommended: 1280x1024 or higher, 32 bit color, 19" monitor  

Processor  

Minimum: 300 MHz P4 128MB RAM  

Recommended: 550 MHz PIII 256MB RAM or higher  

Internet Connection  

T1/T3  

Cable Modem/DSL 

1.3 Computer Configuration  
The Virtual Cell is fully supported under Windows 95/98/NT/XP operating systems. 

Windows 95/98/NT/2000/XP Operating Systems  

The Virtual Cell requires the use of the most current Java 2 Runtime Environment Plug-in  (Download Plug-in) installed with the latest versions of either 
Netscape Communicator or Microsoft Internet Explorer. Your browser should detect whether or not you have the plug-in installed on your computer. 
Netscape will lead you through the installation process while Explorer will perform the installation automatically. 

 

The plug-in is a software product from Sun Microsystems Inc. which enables web authors to direct Java Applets to run using Sun's Java Runtime 
Environment (JRE) instead of the browser's default Java virtual machine. This ensures that Java Development Kit (JDK) based applets are executed 
with full support in Internet Explorer and Netscape. Only those pages that specify the plug-in will use the plug-in. 
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1.4 Using the Virtual Cell Modeling and Simulation Framework with Java Technology 
The Virtual Cell software is currently available to run as the Java applet or the Java Application. In either case, you need to have the Java Runtime 
Environment (JRE) which provides the libraries, Java Virtual Machine and other components needed to run applications over the network, and applets in 
browsers. The applications and applets are written in the Java programming language. 

Java Applet (vcell.org/vcellR4/login/login.jsp) 

The applet is a program that is accessible via a HTML page. The applet code is transferred to the local system and run via the browsers Java Virtual 
Machine (JVM) which executes the instructions from the Java compiler. 

Java Application  

Java standalone software applications can be run over the network from a link within a HTML page. With this technology you will always run the correct 
version of the Java Runtime Environment (JRE). You can get Java Web Start by downloading the JRE, see link above. 

Running the Java Application (vcell.org/webstart/R4/vcell.jnlp) 

In order run the Virtual Cell application, you need to have Java installed on your local machine. If this is the case, click on the application link and your 
machine will recognize the application and lead you to the Virtual Cell login screen. In addition, it will ensure you have the current JRE required for 
running the application.  

If you do not have Java, your computer will most likely prompt you to save the jnlp file since it does not recognize the file type. You need to install Java 
first, (JRE), follow their downloading instructions. Once Java is installed, your computer will recognize the application and bring you to the Virtual Cell 
login screen. 

1.5 User Support  
We have established two emails for contacting the Virtual Cell Developers, one for support and the other for comments and suggestions. There are also 
several tutorials that have been written to help the user become familiar with the software while creating simple models. The tutorials lead the user step 
by step through the construction of the BioModel, Geometry, Application, and Simulation. 

Virtual Cell Support 

Email vcell_support@uchc.edu for assistance with the Virtual Cell. 

Comments and Suggestions 

Email vcell@uchc.edu for comments or suggestions regarding the Virtual Cell. 

Virtual Cell Tutorials  

Tutorials have been provided to work in conjunction with the user guide. The tutorials lead the user step by step through the construction of the 
BioModel, Geometry, Application, and Simulation. 

FRAP- http://www.vcell.org/login/frap.pdf 
FRAP with binding sites- http://www.vcell.org/login/frap_binding.pdf 
Facilitated Calcium Diffusion in the Intestinal Epithelial Cell- http://www.vcell.org/login/facil_ca_dif.pdf 
Hodgkin-Huxley Membrane Potential - http://www.vcell.org/login/membrane_potential.pdf 

 

1.6 Units used in The Virtual Cell 
 
Unless otherwise noted, all units in the Virtual Cell and in this user guide are as follows: 

Current picoAmperes 

Voltage millivolts 

Time seconds 

Length/Distance micrometers 

Concentration (compartments) micromolar 

Concentration (membranes) molecules per micron squared 

Rate (compartments) micromolar per second 
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Rate (membranes) molecules per micron squared per second 

Flux (membranes) micomolar microns per second 

Sufaces Square microns 
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2 An overview of the Virtual Cell Documents 
The Virtual Cell software consists of the BioModel, Geometry, and Math Model documents. 
These are the key components within the software and each is saved independently of the 
other although they do reference each other.  You can open any document from each of the 
document types. BioModel documents are not specific for opening other BioModels. In 
addition, you can have multiple documents open at one time.  

2.1 BioModel Document 
Once the Virtual Cell is initiated, as a default you are presented with the BioModel 
document. The BioModel consists of all the necessary information needed to define the 
biological model, i.e. species, compartments, reactions, fluxes and the Application and 
Geometry. The Application establishes the relationship between the biological model and the 
Geometry.  

2.2 Geometry Document 
The Geometry Document consists of the Geometry Editor and the Surface Viewer for creating, editing, 
and reviewing 1-D, 2-D or 3-D geometries.  

 

 
 

 

 

2.3 Math Document 
The Math Document consists of the VCML Editor, Equations Viewer, Geometry Viewer and 
Simulations. The mathematical description is based on the Virtual Cell Math Description Language, 
VCMDL, a declarative mathematics language that has been developed to concisely describe the 
class of mathematical systems that are encountered in the Virtual Cell project.  

Table of Contents

3. Quick Tour of the Virtual Cell 
The following is a quick tour of the Virtual Cell software from the creation of BioModels to the running of Simulations and viewing of results. 

3.1 Creating BioModels 
The Virtual Cell Software is comprised of two components that are required for generating the 
mathematical code needed for running simulations: BioModels and Geometries. The BioModel 
consists of the model description, and the Application. An Application includes the Structure 
Mapping, Initial Conditions, Reaction Mapping, Electrical Mapping and Simulations. When the 
Application is saved, the Virtual Cell automatically creates the Math Description defining the 
model. A single BioModel may have numerous Applications related to it, in which geometries 
and/or parameters have been changed. In addition, BioModels may have multiple Editions. 
Editions are useful when modifications are made to the same basic model. 

When the software is initiated, a BioModel will automatically open with an empty compartment 
that represents a cellular structure. If you choose to open a second BioModel, go to 
File>New>BioModel on the Virtual Cell menu bar. 
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Defining Compartments  

Use the Feature Tool  to add additional cellular structures. Select the tool and click once within the existing compartment. Membranes are 
automatically created between neighboring compartments.  

Creating Species 

 Use the Species Tool  to create Molecular Species within the compartments. Select the tool once, then click in the compartment where you want the 
species created.  

Defining Reactions 

 Use the left mouse button to select the compartment or membrane and then use the right mouse button within the region to access the Reactions 

menu. Select either the Reaction Icon  or the Flux Icon  to establish a reaction or a flux condition. Use the Line Tool  to connect the 
participating species to the icon. Attach the reactants to the left side of the icon and attach the products to the right side of the icon. Select the icon and 
use the right mouse button to access Properties>Reaction Kinetics Editor to define the reaction, or Properties>Flux Reaction Editor to define the flux. 

3.2 Defining Geometries  
You can create a new geometry document from uploaded experimental images or from analytically defined 
conditions. When you want to create a Geometry, go to New> Geometry>Analytic>1-D, 2-D or 3-D or New> 
Geometry>From Image>Existing Image or Choose Image from File (gif or tif).  Image based refers to an 
experimental image that you have uploaded to the Virtual Cell image database. See Chapter 6, Defining 
Geometries, for more information. Stored geometries are displayed in the Geometry panel of the Database 
Manager (File>Manage Database). Model components referenced by the Geometry are also displayed in the 
directory tree. 

Geometry Editor 

Geometries are created and modified within the geometry editor. Create new geometries from experimental 
images or define them analytically. Edit the domain for your image based geometry, or add an analytic geometry 
to your existing image. 

Surface Viewer 

The surface viewer allows you to view the surface of your 3-D data set and to rotate it in space. It may also be used for 2-D data sets, for viewing the 
edge of a compartment. 

3.3 Creating Applications 
The Application is the component in which you establish the Structure Mapping between your model 
and the geometry, and define the Initial Conditions and Reaction Mapping. In the Application dialog 
you can also view the software generated math code describing the BioModel and the equations 
used in the simulation. 

The Application directory displays the BioModel  that is currently loaded as well as the 

Applications  that are associated with it. In addition, you can expand the tree to display the 

Geometry , Math  and Simulation  or "run" files associated with the Application. 

Structure Mapping  
Structure Mapping defines the relationship between the physiology (cellular structures) and the 
geometry (subdomains). The cellular structures are automatically mapped to a single compartment 
in Compartmental models.  
Define the surface to volume ratio and volume fraction for compartmental models or for unresolved 
spatial structures.  

Use the Line Tool  for Spatial models, to map the cellular structures to the geometric 
subdomains.  
Choose between Flux (Neumann) and Value (Dirichlet) boundary conditions for resolved structures. 
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Initial Conditions  
Initial Conditions and Diffusion Rates may be defined in a spatially dependent manner or as a value for compartment and membrane species, 
for both 2D and 3D models. Specify boundary conditions for non-zero diffusion. 

Reaction Mapping  
Enable or disable reactions and option for Fast kinetics.  

Electrical Mapping  
Specify membrane potential options and electrical stimulus. 

Simulations and Results 
Define simulation run parameters and initiate simulations. The simulator solves the PDEs that correspond to diffusive species and the ODEs 
that correspond to non-diffusive species. 
Compartmental and Spatial simulation results are automatically stored on the database server and immediately accessible for review and 
analysis.  

View Math  
View the equations and the math description which are generated as a result of mapping the physiology model to the compartmental or spatial 
model.  

View Geometry 
Change Geometry option and view surfaces, a 3-D data set option. 

3.4 Describing Math Models 
 You can generate your own mathematical code according to the Virtual Cell Math Description Language, VCMDL, in the Math document. VCMDL is a 
declarative mathematics language, which has been developed to concisely describe the class of mathematical systems that are encountered in the 
Virtual Cell project. This language defines parameters, independent variables, differential/algebraic systems defined over a complex geometry including 
discontinuous solutions and membrane boundaries and the description of the task to perform on such a system.  

You may choose to initially create a BioModel and use the software to generate a math description. You can then import that into the VCML editor and 
alter the math description. Please note that you cannot create a math description and then use the software to create a BioModel from it. 

VCML Editor 

The VCML editor is the text editor for modifying the math description. 

Equations Viewer 

The viewer displays the math description equations describing the constants, functions, volume 
domains, and membrane domain. Parameters may be viewed as either a name or value. 

Geometry Viewer 

View the geometry associated with the model. Additional options include Change Geometry and View 
Surface. 

Simulations 

Define simulation run parameters and initiate simulations based on the mathematical description. 
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4. Managing Your Documents  
The Virtual Cell Modeling and Simulation Framework allows for easy maintenance of models. In order to 
run a simulation, you must create a BioModel, which consists of the biological description, and the 
Application, which in turn consists of Structure Mapping, Initial Conditions, Reaction Mapping, Electrical 
Mapping and Simulations. Although there are numerous components involved, you only need to save the 
BioModel. Any manipulations you make to the components will prompt you to resave the BioModel 
document.  

A Geometry document is required for spatial models. The Geometry is created and saved independent of 
the BioModel, however it references the Geometry file via the Application component of the BioModel. 
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Saving options are available within the document in which you are working. 

Math descriptions are automatically generated via the software when you create an Application. You can take that description and use it as a template 
for a new Math Model or you can create your own Math Model from scratch. Whether you create your own math model or work from the one generated 
by the software, the model is saved independent of the BioModel and Geometry documents.  

4.1 BioModels, Geometries and Math Models 

Saving 

Once you have created a document and are ready to save, go to File>Save, Save New Edition, or Save As for the available saving options. If you have 
simulation results from a model and you modify your BioModel, Geometry or Math model you need to use the Save New Edition option otherwise the 
simulation results will be lost.  

Deleting 

Documents can be deleted only from within the Database Manager. You can access the Database Manager by going to File>Manage Database. There 
is a tab for each of three the documents. Make sure the document you are interested in deleting is closed prior to deleting it. Select the particular 
document you wish to delete and hold down the right mouse button to access the delete function. 

4.2 Applications and Simulations 

Applications 

In order to remove a particular Application of a BioModel, you must be in the Application panel of the BioModel. Select the Application you wish to 
delete, hold down the right mouse button and select the delete function or go to Application>Delete. Deleting an Application changes the biomodel, 
which needs to be re-saved to commit the change.  

4.3 Allowing others to view your models 
Once you have created and saved a complete BioModel, Geometry or Math Model that is suitable for public viewing, you are 
ready to share your model. (If the model does not belong to you, then you can not change public viewing settings). 

Open the Database Manager and select the BioModel, Math Model or Geometry tab. Click on the document you wish to 
share and either go to Edit>Access Permissions or right-click Permission. You now have three options Public, Private or 
Grant Access to Specific Users. 

By default, your model is private which means that only you have permission to view the model. If you choose to make your 
model public to anyone using the Virtual Cell, you can select Public. Other users can save a copy of your model as their 
own, and then have complete access to their own copy, although no modifications can be made to your original copy. 

If you wish to make your model public to specific Virtual Cell users, select Grant Access to Specific Users. Type in the login 
name of each user to whom you wish to give access as a public model and click Add User. These users will be able to 
access your model the same way that they access any other public model. To all other users, this model would be invisible 
(like a private model). Note that when you select Public, the access control list is disabled since all users already have public access. 

4.4 Saving Annotations 
 

Annotations allow you to save text-based notes about a specific BioModel, Math Model, or Geometry. In addition, you can 
save annotations about Applications and Simulations. The Annotation notes are saved with the model so that you or 
anyone viewing your public model can also view the annotations.   

 

Annotations in BioModels, Math Models, Geometries 

You must be within the document to create a new annotation. Go to File>Edit Annotation and the Annotation dialog will open where you can enter your 
notes, press “OK” to accept the entry.  If you wish to remove your annotation, repeat the above procedure and remove the text within the dialog and 
press “OK”, your annotation will be removed from the document.  

Annotations in Applications and Simulations 

Go to the Application panel of the BioModel document. Select either an Application or Simulation and hold down the right mouse button to access the 
Edit App Annotation option or the Edit Sim Annotation option. Enter the text in the dialog as described above. 
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4.5 Comparing Models 
It is difficult to compare models by simply visually inspecting the different components.  Instead, the best way to compare models is with the Compare 
Models feature which automatically performs a side-by-side comparison of all the different components of the 
model.  

To compare models, you can open the tool via the Database Manager from one of the documents, 
File>Manage Database>Compare With>Latest Edition, Previous Edition, or Other (a baseline model selection 
in the Database Manager has to be made before choosing an option in the Compare With menu); or in the 
Database Manager, select the baseline model and use the right mouse button to Compare With>Previous 
Edition, Another Edition or Another Model. In the dialog that appears, select the model you wish to compare 
against your baseline model and press the Open button.   

The models are compared and you are presented with a composite model, where only differences are 
indicated. A X will indicate which part of the model is different. The X will originate at the parent level in the tree 
and travel down the tree wherever there is a difference between the two models.  At the level where that item 
is, it will be marked with an ?. Items that are only in the modified model are marked with an N for new. Items 
that are only in the baseline model are marked with an R for removed; they are considered to be removed from 
the modified model.  

4.6 Exporting and Importing Models 
Models can be easily exported as XML and Matlab files. There are a variety of different formats for the two file types. VCML is the Virtual Cell Markup 
Language and is in the native virtual cell format. SBML and CELLML are two variations of XML that should only be used if you need to import them into 
another program that requires one of these two formats. If you plan on importing the model back into the Virtual Cell, make sure to export a copy as 
VCML. 

The Virtual Cell supports interoperability with other standard representations for biological systems modeling. Specifically, the Virtual Cell provides 
incomplete support for the import/export of BioModels into SBML (levels 1 and 2), and of Bio and non-spatial math models into CellML (version 1.0). In 
addition, the Virtual Cell allows the export of non-spatial math models into Matlab formats (v5 and v6). The following comments are a subset of what 
users should keep in mind when importing/exporting SBML models: 

 Both levels 1 and 2 of SBML are supported, but it is preferable to use level 2, since its more comprehensive. 

 There is no support in the Virtual Cell for ‘event’ elements that exist in SBML. Any such components will simply be ignored. 

 There is no explicit representation in the Virtual Cell for compartment volumes. 

 There is no explicit representation in SBML for electrophysiology based Virtual Cell models. 

 When importing an SBML (level 2) model, it is important to verify that it has the correct topology for the different compartments. This is 
achieved in SBML by specifying the outside attribute for a compartment, and its spatial dimension. Features in the Virtual Cell have a spatial 
dimension of 3, while membranes have a spatial dimension of one minus that of features. 

 To support translation of units, the Virtual Cell may add unit scaling factor parameters to the kinetics formula of an SBML model. 

 The Virtual Cell supports the MathML used in SBML. However, the subset of supported elements may not overlap with what SBML supports 
(e.g. the Virtual Cell does not support the element ‘lambda’). 

 Practically all ‘Application’ related information is lost when exporting a biomodel to SBML. 

Importing Models 

Within the model document go to File>Import and select the XML file that you wish to import.   The model will be imported into the Virtual Cell. 

Exporting Models 

Open the document you wish to export and go to File>Export. Determine where you want to save the model on your local drive and select what format 
you want it to be in. 

Export Formats Available: 

SBML Format Level 1 Version 1 (*.xml) 

SBML Format Level 2 Version 1 (*.xml) 

CellML Format (*.xml) 

VCML Format (*.xml) 

Matlab v5.0 ODE File (*.m) 

Matlab v6.0 ODE Funtion (*.m) 

PDF Files (*.pdf) 
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5. Creating BioModels 
A physiological model of the cell system is defined as a collection of cellular structures, molecular species, reactions and fluxes.  These concepts define 
cellular mechanisms in the context of cell structure and are sufficient to define non-spatial, compartmental models.  A spatial model is defined with the 
addition of cellular geometry, usually in the form of image data collected by various means of microscopy.  The goal is to capture the physiology 
independently of the geometric domain (cell shape and scale) and specific experimental context, such that the resulting physiological mechanisms are 
modular and can be incorporated into new models with minimum modification. 

5.1 Specifying Cellular Structure 
A physiological model is defined as a collection of biochemical reactions acting on a set of molecular species localized in specific cellular structures.  
The cellular structures are defined as mutually exclusive compartments within the cells, as well as the membranes that separate them. The 
compartments represent three-dimensional volumetric regions while the membranes represent two-dimensional surfaces separating the compartments.  
Filaments, e.g. microtubules, represent one-dimensional contours lying within a compartment. (Note, this feature is being developed, but is not yet 
implemented in the Virtual Cell software.) All structures can contain molecular species and a collection of reactions that describe the biochemical 
behavior of those species within that structure. Keep in mind when developing your model that it must be mapped to a specific cellular geometry before 
any quantitative simulation or analysis can be performed.  The software is designed such that you will generate two parallel representations of 
anatomical structures, physiological models and geometric simulation models. This feature allows for the portability of the same model to be used in 
varying compartment and spatial simulations. 

Compartments  

Edit Feature 
Once you start the Virtual Cell software, you are automatically presented with a BioModel document, in which you 
are presented with an initial empty compartment.  When creating your model, you must first create the cellular 
structures, or compartments. You can name the existing compartment by selecting the compartment once, it will 
turn red, hold down the right mouse button to access the Properties menu and open the 
Edit Feature dialog. This will allow you to name the existing structure. Enter a name in 
the Feature Name text field and press OK.  

Add New Feature 

If you wish to add additional compartments, you must use the Feature Tool .  Select the Feature Tool and then click into 
an existing compartment. Enter the names in the Feature Name and Membrane Name text fields feature; press Add 
Feature. Depending on where you add the new compartment, you may be able to specify if you want the new compartment 
placed within the existing compartment or to the outside of the existing compartment. 

Membranes  

Once a structure has been added within a structure, a membrane is automatically generated. To rename the 
membrane and/ or Voltage Name if your model involves membrane potential, select the membrane once, and with the 
right mouse button select Properties>Membrane dialog. Enter the name(s) in the appropriate text field and press OK. 

5.2 Specifying Molecular Species 
Once you have created the compartments, you need to create the molecular species for those compartments. The molecular species represent any 
distinct state necessary to describe the biochemistry of the cell, for example molecular conformation, receptor bound versus receptor unbound. The 
species can be separately defined in multiple compartments, membranes or filaments.  The species are described by linear densities when located on 
filaments (linear species), concentration and diffusion constants when associated with a compartment (volume species), and surface densities when 
associated with a membrane (membrane species). Species can participate in reactions, fluxes, and diffusion. Species diffusion is defined separately for 
each cellular compartment, membrane or filament, and is specified by diffusion constants.  Species may have directed motion along filaments, there 
may be a flux of species through a membrane separating two neighboring compartments and species may be involved in binding reactions between 
compartments, membranes or filaments. (Note that reference to work involving filaments is being developed, it has not yet been implemented in the 
Virtual Cell software.) 

Adding Species 

Select the Species Tool  , in the BioModel document, and click once with the left mouse button in the appropriate 
compartment. The Create New Species Context dialog will open. Enter a descriptive name in the Name text field. 
The Context Name is automatically created for you because it is used in the mathematical equations that are 
automatically generated. This name is necessary to distinguish between Species when they are used in multiple 
compartments.  

Override   
Create the Context Name manually in the Context Name text field, instead of using the one that is automatically generated. 

Annotate   
Add reference notes about the Species you created. 

Add DB link 
Create a binding between your Species and a database. See below for more information regarding Database binding.   
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Add   
Implement the creation of your Species. 

Adding Additional Species 

Use the cut and paste feature to add similar Species to other compartments. Select the Species that has been created and use the right mouse button to 
go to Edit>Copy. Select the new compartment, use the right mouse button to access Edit>Paste. 

Note, you can also add additional Species via the Reaction dialogs. Use your right mouse to access the Add Species option within the Reaction dialog. 

Moving Species 

Select the Species and use your right mouse button to access the Cut function. Select a new compartment or membrane and use the right mouse button 
to access the Paste function. 

Database Binding  

You can bind a Species to KEGG (Kyoto Encyclopedia of Genes and 
Genomes) by using the Database Binding function. Here you can select 
for a Compound, Enzyme or Protein by name or keyword. This performs 
queries using the Swiss-Prot Protein Knowledgebase from EBML. It 
queries KEGG's ligand database for Compounds and its enzyme 
database for enzymes. Enter a name in the Search Filter text field and 
press the Search button. You may search in your own models, all public 
models, or the database dictionary. The detailed information from your 
search includes: abbreviated name, common name, accession number, 
and organism. Once you have found your entry, select it and press OK. 

Note the information for the database reference link is displayed in the 
New Species dialog. Species that are bound to the database appear light 

green in color, while those that are not bound appear dark green. 

If you wish to break the database binding, select the Species and use the right mouse button to access the Properties menu which opens the Edit 
Species dialog. Press Unlink, confirm your option and press OK. 

Channels, Pumps and other Membrane Associated Species 

As mentioned above, a membrane is created once a structure is added to another structure, and once you have created a membrane you can add 
channels, pumps or other membrane associated species using the Species tool. 

Select the Species tool and click once on the membrane to position the Species on the membrane. Use the Species tool as described above. 

See the section on Membrane fluxes for instructions on how to incorporate a pump or channel into a flux reaction. 

5.3 Editing Properties of Model Components 
As you create your model, you may have to change properties of the model components or remove the components.  Select the Species or 
Compartment and use the right mouse button to access an item specific menu. The choices for Species are Copy, Cut and Properties, and the choices 
for structures are Delete, Paste, Paste New, Add Feature, Add Species, Reactions, Properties, Model Parameters, and Save as Image. The Membrane 
menu items are Paste, Paste New, Add Species, Reactions, Properties, Model Parameters, and Save as Image. The Properties selection for Species 
brings up the Edit Species dialog for that particular Species and for Structures it brings up the Edit Feature dialog for that particular Compartment. The 
Properties selection for membranes opens the Membrane Dialog.  

If you wish to delete a compartment, first select it and then use the right mouse button to access the Delete function. If you wish to delete a Species, you 
must first select it and then use the right mouse button Cut function. Please note that you cannot delete a Species if it is involved in a reaction.  You 
need to remove it from the reaction first and then you may delete it. 

5.4 Specifying Biochemical Reactions 
The biochemical reactions are objects that represent complete descriptions of reaction stoichiometry and kinetics. Reactions can be either a collection of 
related reaction steps occurring at or near a single structure (e.g. membrane receptor binding, cytosolic calcium buffering), or transmembrane fluxes 
(e.g. flux through an ion channel). Each reaction step is associated with a single cellular structure. The stoichiometry of a step is defined in terms of 
reactants, products, and catalysts, which are related to species in a particular cellular structure.  It should be pointed out that reaction steps in a 
compartment involve only those species within that compartment, whereas reaction steps on a membrane involve the species on that membrane as well 
as the species present in the compartments neighboring the membrane.  Reaction steps on a filament involve the species present on that filament as 
well as the species in the compartment, which houses that filament.  Numerically, the reaction rates and fluxes are represented symbolically by arbitrary 
algebraic expressions in terms of parameters and species concentrations. 

 10



Compartment Reactions  

 Use the left mouse button to select the compartment of interest and then click with the right mouse button to get access 
the options menu. Select Reactions from the menu to open the Reactions dialog. 

Select the Reaction Tool  and click once on the canvas.  Use the Line Tool  to draw from the Reactant Species 
to the Reaction Icon. Reselect the Line Tool and draw from the Product Species to the Reaction icon. Select the 
Reaction icon and use the right mouse button to access the Properties option to open the Reaction Kinetics Editor. If 
necessary you can delete the line between the Reaction Tool and Species. Select the line with the left mouse button 
and then use the right mouse button to access the Delete option.  

 

 

You can manually arrange the reaction diagram by selecting the Species or Reaction icons and repositioning 
them. Use Shift for making multiple selections. You also have the option of making rubber band selections. 
Alternatively you can choose from a variety of different graph layout algorithms (random, circle, anneal, levelor, 
relaxor, and glg) for arranging the reaction diagram. Sometimes the best layout results are achieved by using a 
combination of the different algorithms. 

Stoichiometry 

By default, the stoichiometry of a reaction is 1 however you have the option of 
changing it. Use the left mouse button to select the line connecting the Species to 
the Reaction Tool and then use the right mouse button to access the Properties 
menu. Enter the value for the reaction; press OK.  The reaction line will update 
accordingly. Note the stoichiometry is displayed only when the value is something other than one. 

Reaction Kinetics 

At present, reaction kinetics consists of General, Mass Action, Henri-Michaelis-Menten (Reversible), and Henri-
Michaelis-Menten (Irreversible).  

General Kinetics  

General Kinetics can be specified by an arbitrary rate expression defined in terms of reactants, products, and 
catalysts in the Reaction Kinetics Editor. Select the Reaction Icon and use the right mouse button to access the 
Reaction Kinetics Editor via the Properties option.  Select General for Kinetic Type from the selection list. 

 
 
Rename   

Opens the Reaction Name dialog for identifying the reaction. Enter a reaction name in the text field; press OK to accept the name and 
close the dialog. This name will appear under Applications>Reaction Mapping>Name for referencing the reaction, so you may want to 
use something informative. 

Parameter and Expression  
Supply the rate information and press Set to accept the entry. In the event you have added a parameter to the equation, you will have to 
define the expression for the parameter. The parameter may be a variable, a constant, or a combination of both. Double click the 
parameter then enter the appropriate expression in the Expression text field; press Enter. When defining parameters within the 
physiological model, the expression must be spatially independent. However, an expression may have spatially dependent variables 
when defined under Initial Conditions in the Application component of the Virtual Cell. 

Mass Action Kinetics  
Select the Reaction Icon and use the right mouse button to access Properties>Reaction Kinetics Editor. Select 
Mass Action Kinetics for Kinetics Type from the selection list.  Note that when you select Mass Action, you will 
automatically be prompted to provide foward and reverse rates (Kf and Kr) for the appropriate species. 

Rename  
Opens the Reaction Name dialog for identifying the reaction. Enter a reaction name in the text 
field then press OK to accept the name and close the dialog. This name will appear under 
Applications>Reaction Mapping>Name for referencing the reaction, so you may want to use 
something informative. 

Parameter and Expression   
Double click the Expression text field in order to supply the rate information. In the event you have added a parameter to the equation, 
you will have to define the expression for the parameter. The parameter may be a variable, a constant, or a combination of both. Double 
click the parameter then enter the appropriate expression in the Expression text field and press Enter. When defining parameters within 
the physiological model, the expression must be spatially independent. However, an expression may have spatially dependent variables 
when defined under Initial Conditions in the Application component of the Virtual Cell.   
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Michaelis-Menten Reaction  

You can choose between Henri-Michaelis-Menten 
(Reversible), and Henri-Michaelis-Menten (Irreversible) from 
the selection list. You will be prompted to supply values for 
Vmax and Km for the reaction. Use a molecular species to 
represent a catalyst. Be sure to connect the catalyst to the  
middle of the Reaction icon and not to either end as you do 
for the reactant and product. 

 

Membrane Reactions 

Use the left mouse button to select the membrane and then use the right mouse button to access the Reactions menu. The Reactions dialog for the 

selected membrane will open. Select the Reaction Tool  and click once in the middle column, which represents the membrane. Use the Line Tool  
to draw from the Reactant Species to the Reaction icon, reselect the line tool and draw from the Product Species to the Reaction icon.  If necessary, you 
may delete the line between the reaction tool and species. Select the line with the left mouse button, and then use the right mouse button to access the 
menu with the Delete option.  The line connecting the reactant(s) and product(s) to the reaction tool also specifies the stoichiometry for that reaction if it 
is other than one. (See Stoichiometry for further information.) Select the Reaction icon and use the right mouse button to go to Properties >Reaction 
Kinetics Editor. See Reaction Kinetics for information on the Reaction Kinetics Editor. 

Membrane Fluxes  

Fluxes are associated with a single membrane and describe the flux 
of a single species through that membrane.  The flux species must 
be a species that is present in both neighboring compartments.  A 
single inward flux is defined by convention (µM*µm*s-1) and 
enforces flux conservation across the membrane.  The flux is an 
arbitrary function of flux carrier and catalyst concentration in the 
membrane's neighboring compartments and of membrane bound 
catalyst surface density. 

 

Use your left mouse button to select the membrane of interest and 
then click with your right mouse button to select the Reactions 
option.  

Select the Flux Tool  and click once in the middle column, which represents the membrane, to apply the 
channel.  The Flux Reaction Editor will open automatically. 

Rename  

Opens the FluxReaction Name Dialog. Type in a name describing the flux reaction, press OK to accept it and dismiss the window. This name 
will appear under Applications>Reaction Mapping>Name for referencing the reaction, so you may want to use something informative. 

Change   
Select the flux carrier by pressing Change. Choose the appropriate species from the Species Selection dialog, press OK. Once you choose 
the Flux Carrier, the software will automatically connect the species to the flux icon. 
 

Kinetic Type   

Choose the kinetic type from the combo box. The available options are General mass flux, General current density, Goldman-Hodgkin-Katz permeability, 
Nernst conductivity. Depending on your selection, options such as Molecular Flux, Electric Current and Charge Valence may become enabled. 

General Mass Flux (µM-µm/s) 
Double click the Expression text field and enter the equation defining the inward flux rate. Press Enter to accept the value. If you have added a 
parameter to the flux equation, you will have to define the expression for the parameter. This parameter can be a variable, a constant or a 
combination of both. Double click the Expression text field to key in a value and press Enter to accept the value. 

General Current Density (pA/µm2) 
Enter the equation defining the inward current in the Expression text field, press Enter to accept your value. The inward flux rate is updated 
and displayed. Any parameter added to the current equation must be defined. 

Goldman-Hodgkin-Katz Permeability (µm/s) 
Specify the expression for permeability in the Expression text field, press Enter to accept your value. The inward current expression is 
calculated automatically and displayed. Any parameters introduced in the permeability expression need to be defined in the Expression text 
field. 
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Nernst Conductance  (nS/µm2) 
Specify the expression for conductivity, press the Enter key and the Set button to 
accept the value. The inward current expression is calculated and displayed. Any 
parameters introduced in the permeability expression can be set as described for 
General mass flux. 

Adding Searchable Database Reactions 

You can easily add reactions to your model by using two databases connected to the 
Virtual Cell and KEGG Reaction Database. 

To Compartments and Membranes 

 
In the Reactions dialog, hold down the right mouse button to access the Add Searchable 
Reaction option; the Create Reaction dialog will appear. Your search may be conducted in 
the User Reactions Database or the Dictionary Reactions Database. The User Reactions 
Database scans all public models within the Virtual Cell and the Dictionary Reactions Database uses the KEGG Reaction Database. Within either 
database, you can perform a search based on a reactant, an enzyme, a product or any of the three types. 

Select either User Reactions or KEGG Enzymatic Reactions, and then select Text or KEGG 
Molecular/SWISSPROT Protein.  When you select KEGG Molecular/SWISSPROT Protein, you will be 
prompted to specify at least one search condition. This will open the dialog for searching the KEGG database 
for a compound or an enzyme that will be used in 
your reaction search. Enter your description in the 
search filter text window and select where you wish 
to search from. Select either the compound, enzyme 
or protein tab.  

Select the result you are interested in and press ok. 
Press next in the Create Reaction Dialog. Your 

search results are displayed in a new dialog. Select a reaction from the list. The reaction 
version and reaction details are displayed below; 
choose a version of the reaction and press Next. 
Assign the Reaction Elements to the Model 
Species, either New Species or existing Species, 
and press Finish. The complete reaction will be 
displayed in the reaction dialog. 

You may use the Back button at any time to 
modify the searchable reaction you are creating. 

 

Using Partially Defined Enzymes 
Occasionally there may be enzymes that are not specifically returned in the search results. The database reference will list a number that refers to a 
group of enzymes, but not to a particular enzyme. If such a reaction is selected ,you may change the binding to a more specific enzyme. Use the 
Species tool and connect the new Species to the middle of the reaction icon. The words “Catalyst” should appear when you make this connection. This 
new Species can now be defined as the enzyme within the reaction. 

Adding Channels and Pumps 
Channels and pumps need to be connected to the Flux icon in a certain order otherwise they will be incorrectly 
recognized as parameters in the reaction equation. Once you have selected the Flux carrier, close the Flux Reaction 
Editor. Use the Line tool to connect the pump or channel to the middle of the Flux icon. The connecting line will be 

grey instead of black, and the words <Catalyst> will appear as you make the connection. Select the membrane and then use the right mouse button to 
open the Flux Reaction Editor via the Properties menu. 

Once the pump or channel is connected, it will appear in the Flux Reaction Editor and can be used in the rate equation. 

Table of Contents

6. Defining Geometries 
Each model that is developed requires a detailed description of the cellular geometry to represent the behavior of the cellular system.  A geometric 
model represents the morphometry of a particular cell, or a portion of a cell. A typical cell contains various structures that can span a few orders of 
magnitude in scale. The geometry may be captured by various imaging modalities such as wide field, confocal, or electron microscopy. The decision to 
include small structures, i.e. intracellular mitochondria, depends on the ability to experimentally resolve such anatomical structures and the spatial scale 
of interest. Internal structures that are included in the physiological model, but are not spatially resolved, may be mapped continuously (distributed) as a 
volume fraction of the enclosing compartment. In order to properly define a simulation domain, the geometry must be specified as 2-D or 3-D segmented 
images (based on pixel intensity) with the appropriate scaling information (pixel size defined in microns). Segmentation is necessary to establish the 
discrete regions that represent the anatomical features of interest. Membranes are implicitly represented as the boundary between dissimilar 
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compartments. For very regular structures or symmetric cells, analytic geometry may be used to define the cell geometry instead of experimental 
images.  It must be stressed that the simulation domain must still be defined. 

6.1 Compartmental Geometries 
A compartmental model represents a single point simulation based on the 
defined physiological model and the geometric assumptions, the Surface to 
Volume Ratios and Volume Fractions. Compartmental models are not spatially 
resolved and they are solved using nonlinear ordinary differential equations. 
These equations are generally computed within seconds.  

Open the Application by going to the Application panel within the BioModel 
document and selecting Application>New. Enter a name for the Application in 
the Application text field. 

By default, the Application will load with a Compartmental model already 
mapped according to the biology you have described for your model. You can 
see the structures in your description are mapped to a single compartment. 

 

6.2 Spatial Geometries 
In a spatial model, you can use an image that you have generated from experimental data, as described before, or you may specify one analytically as 
an ordered list of inequalities, or you may have a combination of both.  

Creating an Analytic Geometry 

An analytic geometry must fulfill the following two requirements: 

1. Every point in the domain must belong to one subVolume 

2. All subVolumes created must be resolved. 

The software will not allow you to save a Geometry unless these two conditions have been met. In addition 
please note that X,Y,Z, and T are not reserved symbols for defining a geometry, you must use x,y,z, and t. 
The reserved symbols are case sensitive. 

In the BioModel document, go to New>Geometry>Analytic and select 1-D, 2-D, or 3-D. The Geometry 
document will open and you can edit your Geometry in the Geometry Editor. The default subVolume has a 
value of 1.0, which refers to all points other than those defined in the preceding subVolumes. 

Add  

Press Add for each subVolume you would like to create. Double click on the name field to edit the name and double click on the value field to 
define the subVolume. Press Enter after each entry to accept the change. 

Change Domain   
Press this to access the Geometry size dialog. The domain contains the actual image size (the scale of 
a pixel specified in microns) and the origin. The origin refers to the coordinates relative to the analytic 
geometry. Enter the appropriate values for each coordinate and press OK. 

Front/Back   
Use to arrange the layers of the defined analytics. You need to select a subVolume in order for the buttons to become enabled. Please note 
that the decomposition of a domain into compartments can depend on the order in which the subVolumes are created. Use the Front and 
Back buttons to change the order of the subVolumes such that the proper order is obtained. The subVolume list and image display panel will 
update as you make changes. The subVolumes are listed in the proper order when you can see all the subVolumes you created in the image 
display panel. 

Delete  
 Remove the selected subVolume. 

Slice   
Step through a 3-D geometry by increments of 1 or 10. 

Axis   
Change the orientation of the geometry by choosing XY, YZ or ZX. 
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Defining Equations 

Circle  
With center M(a,b) and radius r: (x-a)2+(y-b)2=r2, this can be written in the 
Virtual Cell as: ((pow((x-#),2)+pow((y-#),2))<pow(#,2)) or ((x*x + y*y))<#).  
In the first equation, the x and y #s position the circle and the last # defines 
the size of the circle. In the second equation, the # defines the size of the 
circle and you use the domain to position the circle. 

Square 
A square can be defined in the Virtual Cell as:  (x>#)*(y>#)*(x<#)*(y<#). 

 

Once you have defined your Geometry, save the description by going to File>Save As and enter a name in the Save Document text field.   

Creating Image Based Geometries 

In the Virtual Cell you may use images generated from experimental data to define your Geometry. The images must be segmented gif images, where 
the segmented area represents a single compartment of region of the model. In the BioModel document, go to File>New>Geometry>From Image and 
select either Existing Image or Choose Image from File. If this is your first Geometry select Choose Image from File and navigate on your local drive to 
select the segmented image. Your image will be brought up in the Edit Image dialog.  

Edit Image 
Size  

The image size is displayed in pixels and in microns. You may edit the micron size with regards to X, Y and Z. 
Image Annotation 

Enter descriptive information about the image.  
 

Prev, Next and Name  
Use the Prev and Next buttons for stepping through the compartments making up the image Geometry. Enter 
a descriptive name for the selected compartment in the Name text field.  When the selection is active, the 
compartment will turn red.  

Import, Cancel 
Press Import to bring your image based Geometry into the Geometry document. Press Cancel to terminate this 
process. 

 

Geometry Editor 
Once you import your image, it will open in the Geometry Editor in the Geometry document. The software generates its own color map, for display 
purposes, based on the arrangement of the different compartments. The color map is not intensity dependent. The image is interactive; as you move the 
mouse pointer over the image it will display the image coordinates. 

Add   
Press Add for creating additional analytically defined subVolumes. Double click in the Value field to define the subVolume. Double click on 
the name field to rename the subVolume. 

Change domain  
 Press this to access the Geometry size dialog. The domain contains the actual image size (the scale of a 
pixel specified in microns) and the origin. The origin refers to the coordinates relative to the analytic 
geometry. Enter the appropriate values for each coordinate and press OK. 

Front/Back  
 Use to arrange the layers of the defined analytics. You need to select a subVolume in order for the 
buttons to become enabled. Please note that the decomposition of a domain into compartments can 
depend on the order in which the subVolumes are created. Use the Front and Back buttons to change the 
order of the subVolumes such that the proper order is obtained. The subVolume list and image display 
panel will update as you make changes. The subVolumes are listed in the proper order when you can see 
all the subVolumes you created in the image display panel. 

Delete  
 Use to remove the selected subVolume. 
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Slice 
 Use to step through a 3-D geometry by increments of 1 or 10. 

Axis  
 Change the orientation of the geometry by choosing XY, YZ or ZX. 

 

Table of Contents

7. Using Applications 
Once you have defined your biological model and created a Geometry, you need to establish the association between the two such that the Geometry is 
properly mapped to the biology. You use the Application component of the Virtual Cell software to accomplish this. The Application consists of Structure 
Mapping, Initial Conditions, Reaction Mapping, Electrical Mapping and Simulations. 

In the Applications dialog you can also view the Math description of your model, update the Math description and View/Change the Geometry.  

When creating a new Application, go to the Application panel of the BioModel, and select Applications>New, and provide a name for the new Application 
in the text field. 

7.1 Structure Mapping 
You establish the relationship between the BioModel and Geometry documents in the Structure Mapping panel. By default, the Application will load with 
a Compartmental model mapped according to the biology you have described for your model.  

Compartmental Model 
In the compartmental model, the structures defined in your model description are mapped to a single 
compartment. A compartmental Application represents a single point simulation that is based on the defined 
physiological model and the geometric assumptions, the Surface to Volume Ratios and Volume Fractions.  

Surface to Volume Ratio   
You must specify the surface to volume ratio for compartmental models, or for regions that are not 
spatially resolved, continuously distributed. The Surface to Volume Ratio is needed to convert mass 
into concentration.  
Double click the SurfVol column for the appropriate Structure; type in a value and press Enter.  

Volume Fraction   
The Volume Fraction defines what amount the enclosed compartment occupies of the total structure.   
Double click the VolFract column for the appropriate Structure; type in a value and press Enter.  

Spatial Model 
Once you create a new Application, go to View/Change Geometry and press Change Geometry to access the Select new geometry dialog. Select the 
Geometry folder and press Open.  

Once you select a new Geometry, the Structure Mapping will immediately update, displaying the Geometry (subdomains) and the structures described in 
the biology. Close the View Geometry dialog. 

Each mutually exclusive volumetric region in the geometry is mapped to a single compartment and an interface separating any two regions is mapped to 
the corresponding membrane. You do not have to physically map the membranes; this is integrated in the software as you map neighboring 
compartments. A compartment that is not spatially resolved in the geometry may be considered continuously distributed within the geometric region of 
its parent compartment. Even though a region is described as being continuous it does not have to be uniformly distributed within its parent 
compartment, for example the endoplasmic reticulum in the cytosol. The endoplasmic reticulum is a highly complex structure that would require very 
small spatial steps to resolve. It is better to consider such a structure as being distributed within its parent compartment. 

Resolved Mapping Distributed Mapping 
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Line Tool 

You must manually map the physiology (structures) to the geometry (subdomains) using the Line Tool  . Select the Line Tool and draw 
from the cellular structure to the geometric subdomain representing that structure.  You must reselect the line tool each time you map a new 
region.  

Surface to Volume Ratio  
The Surface to Volume Ratio is needed to convert mass into concentration. This is required for continuously distributed compartments in 
order to reconcile distributed fluxes and membrane binding rates to the spatially resolved compartments. Double click SurfVol, enter the 
value and press Enter. 

Volume Fraction 
For continuously distributed compartments, the Volume Fraction is required to reconcile distributed fluxes and membrane binding rates to 
the spatially resolved compartments. The Volume Fraction defines what amount the enclosed compartment occupies of the total structure.  
Double click VolFract, type in the value and press Enter. 

Set Boundary Types   
For resolved structures, you may choose 
between Flux (Neumann) and Value (Dirichlet) 
Boundary Conditions.  The boundary conditions 
types, surface density or flux, are taken from the 
enclosed compartment. For example, the 
plasma membrane takes its boundary condition 
type from that specified for the cytosol. When 
modeling only part of a cell, the boundary 
conditions are only applicable for membranes 
that intersect the box defining the simulation domain.  
 
Select the structure and press Set Boundary Types. Conditions by default are Value however you can change them to Flux in the choice 
box. Press OK once you have made your selection. 

7.2 Initial Conditions  
In the Initial Conditions panel, you are able to define species concentrations, set concentrations to be fixed, and confine the concentration of a variable 
or variables to a certain region or regions within the model.  

Initial Conditions  
Double click the Initial Conditions column in order to enter a value or equation in the 
Expression Editor dialog.  An equation may be used to restrict the concentration variable to 
a certain region within the model. For example, you might restrict the concentration of a 
variable, 1000, to a given region, defined by the y coordinates, by the following equation: 
((1000.0 *(y<0.89)) + (1000.0 * (y>= 0.89))). In addition you may also define such 
concentrations with a time dependent component. 

Fixed Concentration   
A species' concentration can be set to Fixed. A constant state maintains the concentration 
of the selected species; the species is neither broken down nor produced.  The species in this case is no longer a variable but instead 
becomes a parameter.  Known concentrations may be held constant in a reaction in order to aid in determining unknown concentrations of 
other species elements.  

Diffusion Rate  
Diffusion rates can be defined, in a spatially dependent manner or as a value, for compartment and membrane molecular species. This is 
applies to both 2D and 3D models. Membrane and bulk diffusion rates are specified in the same manner. Double click on the Expression 
text field and enter your value or expression. As an example, the diffusion constant may be spatially defined by the following equation: 
(300.0*((y<2.23) + (y>4.0))), where the value of 300 is confined within the area defined by the y coordinates. In addition, you may also 
define such concentrations with a time dependent component. 

7.3 Reaction Mapping  
There is often a wide range of time scales in interrelated cellular processes that pose a problem when 
computing numerical solutions. The Virtual Cell software has been designed based on the separation of fast 
and slow kinetics. You can specify the subset of reactions that have fast kinetics and the fast system will 
automatically be generated and integrated into the mathematical description by selecting or deselecting the 
option. 
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7.4 Electrical Mapping 
Electrical Mapping specifies the Membrane Potential Options and Electrical Stimulus that can be applied to flux reactions. The Membrane potential 
options table lists the membranes in the biomodel and the user has the option of specifying the initial 
voltage (V initial) and the specific capacitance of each membrane. By default the checkbox for 
calculating the voltage is checked. 

The user can choose between three options for the applied electrical stimulus: no clamp, voltage 
clamp or current clamp. If you switch from the voltage/current clamp to any other clamp options, a 
warning message will be displayed indicating that the present clamp settings will be lost. 

Electrical Mapping is available in both Spatial and Compartmental models. In Compartmental models 
you cannot specify clamp or electrode position. 

No Clamp   
There is no stimulus applied across the membrane, so no clamp device is displayed. 

Voltage Clamp  
A voltage clamp or stimulus is applied across the membrane. When the voltage clamp 
radio button is selected, the required attributes for the voltage clamp device, i.e., the feature and tip position of the probe electrode, and the 
voltage expression (in milliVolts) can be specified. The features in the Biomodel are listed when the Set button corresponding to the 
‘Features ‘ label is pressed. Remember to press the Set button after specifying the co-ordinates of the tip position and voltage expression. 
The attributes of the ground electrode for the voltage clamp device (i.e., feature name and tip position) can also be specified in this panel. 

Current Clamp   
A current clamp or stimulus is applied across the membrane. When the current clamp radio button is selected, the required attributes for the 
current clamp device, i.e., the feature and tip position of the probe electrode, and the current expression (in picoAmperes) can be specified. 
The features in the Biomodel are listed when the Set button corresponding to the ‘Features ‘ label is pressed. Remember to press the Set 
button after specifying the co-ordinates of the tip position and current expression. The attributes of the ground electrode for the current 
clamp device (i.e., feature name and tip position) can also be specified in this panel; spatial models only. 

7.5 Generating and Viewing the Math Description  
Once an Application is created, the software automatically generates the Math Description. The mathematical description is automatically generated 
once you begin defining your BioModel. It is not constantly updated as you create your model therefore if you wish to view a current description you 
need to use the Update Math option. The other alternative is to save your model. A complete, up-to-date mathematical description is generated with 
each BioModel save. Press the View Math button to open the Math Viewer dialog. 

Equations   
The Equation Viewer displays all the equations generated from the geometric mapping of the model. It is 
displayed in a tree-structured directory so you can view the math description's defined constants, functions, 
volume domains, and membrane domains. Please note that the Equation Viewer is not for editing but for 
viewing purposes only.  You must use the Math Editor for editing equations. You can this access by going to 
File>Open>MathModel. 

Show Parameter 
 Use the radio buttons to choose between a parameter being displayed in the equation as a 
name or as a value. 

VCMDL  
The VCMDL, Virtual Cell Math Description Language, tab displays the math used in the simulation. Please note 
this is for display purposes only. If you are interested in editing the math description, please see Chapter 11 
Creating Math Models. 

 

 

 

 

7.6 Simulations 
You can run a simulation once you have defined your biology and created an Application. The appropriate solver for compartmental models (ODE) or 
spatial models (PDE) will automatically be implemented based on the mathematical description. 

The compartmental simulation (preview) executes a single point simulation based on the defined physiological model and the geometric assumptions, 
surface to volume ratios and volume fractions.  The ordinary differential equations (ODE), for single point approximations, representing the reactions 
kinetics are generated and passed to an interpreted ODE solver (within the client applet).  This system of equations is solved using one of a variety of 
integration schemes.  The set of nonlinear ODE equations are typically solved in seconds.  It allows an interactive modification of parameters and a 
quick determination of the effect over time.  In addition, the Virtual Cell software computes the local sensitivity (Sensitivity Analysis) of any species 
concentration to any parameter as a function of time evaluated at the nominal solution. 
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The Math Description consists of partial differential equations that correspond to diffusive species and 
ODEs for non-diffusive species. The equations are sent to the remote simulation server where an 
executable is generated, run and the results are collected and stored on the data server.  The 
simulation data server coordinates the client access to the server-side simulation for display and 
analysis. 

 Simulator 
On the Simulation panel, you create, define and run your simulations as well as view the results. The 
Simulation Summary is updated each time a simulation is selected. This feature allows you to quickly 
review the run conditions for a simulation and to view parameter values that may have been changed. 
Such values will appear in red text under Parameters>Actual Value. The Simulation Summary panel 
cannot be edited. Conditions for a Simulation are set in the Edit dialog. 

Name   
Double click on the Name text field to define a name for your simulation. Press Enter to accept the text. 

Last Saved   
Displays the date when simulation conditions were established and saved. 

Running Status  
Displays status (submitted, queued, dispatched, initializing or completed) and progress of simulation. 

Results  
Yes, results are available or No, results are not available. 

New  
 Creates a new simulation. 

Copy  
Creates a copy of the selected simulation. 

Delete   
Deletes the selected simulation. 

Run  
Initiates the simulation. 

Stop  
Terminates the simulation. 

Results  
Once a simulation has started and/or is complete, press the Results button to view the simulation results. Note that the simulation must 
be selected for this button to be enabled. 

Comments 
Enter descriptive comments pertaining to the simulation directly in the Comments text 
field. 

Edit  
Opens dialog with additional runtime features: Parameters, Mesh, Task and 
Advanced tabs. 

 
 Parameters  

Displays a summary list of the Parameters and the Actual and Default Values used in 
the simulation. Double click on the Actual Value column, type in a new value and 
press Enter to accept the value. Note that values that have changed appear in red. 
Altering Parameter values allows you to quickly and easily modify your model description 
without having to make a complete new BioModel or access the BioModel dialog. All 
changes and subsequent runs can conveniently be performed in the Simulation dialog. 

 
 Mesh - Specify Geometry size and Mesh size for Spatial models. 

Geometry Size  
Displays the size of the associated geometry, in microns. Geometry size is defined in 
the Geometry Editor. 

Mesh Size  
Default size corresponds to the experimental image data size and/or any defined 
analytic geometries. 
 Task - Specify run time, save interval and sensitivity analysis. 
Start Time  

Specifies time at which simulation is initiated, in seconds. 
Time Step  

Specifies the time points for when the solution is computed, in seconds. 
End Time  

Displays the duration of Simulation, in seconds. 
Keep every X time samples   

Define the save interval; save all or save selected data time points. 
Perform Sensitivity Analysis on Parameter  

Select the check box for performing the local sensitivity (Sensitivity Analysis) of 
any species concentration to any parameter as a function of time evaluated at 
the nominal solution. Use the down arrow to access the list of parameters you 
can choose from. 
It is important to determine the sensitivity of the simulation results to the choice of 
which physiological mechanisms are incorporated and their parameter values.  For a given model structure, the selection of 
parameter values are constrained, but often not completely determined, by direct empirical measurements and physical limitations, 
as well as inferred from the steady and dynamic behavior and stability of the composite system. It is informative to determine the 
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relative change in a model behavior due to a relative change in parameter 
value. Select this feature prior to running the simulation. If you do not make 
this selection prior to running the simulation, you will not be able to perform 
the analysis. 
 

 Advanced - Intended primarily for the more advanced user, this allows for the 
modification of additional integration settings. 
Integrator: The numerical integration algorithm to use. 

Forward Euler (first order) 
Runge-Kutta (second order) 
Runge-Kutta (fourth order) 
Adams-Moulton (fifth order) 
Runge-Kutta-Fehlberg (fifth order) 
LSODA (Variable order, Variable Time Step) 
 

 Integration Settings 

Integrator The numerical integration algorithm to use. 

Time Bounds: Starting The start time. 

Time Bounds: Ending The end time. 

Time Step: Minimum The minimum time step to use (variable time step methods only). 

Time Step: Default The time step (for fixed time step methods only). 

Time Step: Maximum The maximum time step to use (variable time step methods only). 

Error Tolerance: Absolute The maximum acceptable absolute error (variable time step methods only). 

Error Tolerance: Relative The maximum acceptable relative error (variable time step methods only). 

Keep Every X Points Only store every X point(s) (for use in reducing large datasets) 

 

Brief notes on Ordinary Differential Equation Solvers 

(Taken from Piche) 

Once you have created your model, you will rely on numerical solvers for approximating the solution to your problem. The Advanced tab on the Edit 
dialog of the Simulation panel provides the Virtual Cell user with several different ODE solvers to choose from:  

Forward Euler (first order) 

Runge-Kutta (second order) 

Runge-Kutta (fourth order) 

Adams-Moulton (fifth order) 

Runge-Kutta-Fehlberg (fifth order) 

LSODA (Variable order, Variable Time Step) 

The solvers differ with respect to fixed or variable time steps, explicit or implicit, one step or multistep and low or high order. As the user, it is up to you to 
choose the best algorithm for approximating the solution to your problem. 

Fixed Time Step vs. Variable Time Step 

The simplest algorithms use a fixed time step h. Values are computed at times t0, t0+h, t0+2h, ....t0+ph. 

Advanced solvers use varying time steps. The solvers follow the accuracy of the solution during the computation and adaptively change the step size to 
maintain a consistent level of accuracy. The step size may often vary during the time of the computation, with large time steps being used when the 
solution varies slowly and small time steps being used when the solution varies rapidly. 

The variable time step solver is more complicated than the fixed step solver. The solver must estimate the accuracy and control the step size. During the 
computation, the variable time step algorithm follows a sequence similar to the following: 

Based on information from previous time steps, hj is chosen as the next time step. 

The solution at the next time point tj+hj is computed. 

The solution at time tj+1 is computed a second time using a more accurate formula. 

The accuracy is estimated by comparing the two approximations of y(tj+hj). 

The solution moves to the next time point tj+1 if the accuracy is acceptable. A smaller time step hj is chosen and the algorithm returns to step 2 if the 
accuracy is unacceptable. 
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A variable time step algorithm can generate specific time points by interpolating the computed solution points. This is much more efficient than 
computing values at all time points. 

A variable time step algorithm tends to be faster than a fixed time step algorithm. The variable time step version focuses on time intervals that need 
more computation. This balances for the extra computation time needed for error estimation, interpolation and step size adjustment. 

Variable time step algorithms tend to be more reliable than fixed step versions. By reducing the time step, they can handle sharp changes in the 
solution. A fixed time step would generate erroneous results when faced with such a situation. In addition, a variable time step algorithm guarantees that 
numerical instability does not occur. 

One step vs. Multistep 

One step algorithms treat each new time step computation as an initial value, they do not use previously computed solution points. The Euler method 
and the Runge-Kutta method are both one step algorithms however the Runge-Kutta method requires four evaluations of the function f per time step. 
The Euler method requires only one evaluation. The classic Runge-Kutta method computes Yj+1 using the previous solution value Yj and a weighted 
average of the slopes at four points. 

Multistep algorithms use k+1 previously computed solution values Yj, Yj-1, ...Yj-k to compute the next solution value Yj+1. The Adams method is an 
example of one such multistep algorithm. The solution point Yj+1 is computed using the solution value Yj and a weighted average of the slopes at 
several time points. 

Multistep algorithms required fewer evaluations of the function f per time step than one-step versions because they can store values from previous time 
steps and then reuse them. The Adams method needs to evaluate f once per time step while the classic Runge-Kutta method requires four evaluations. 
However, one step algorithms are usually faster because of differences in accuracy and in computational complexity. 

Explicit vs. Implicit 

Implicit algorithms, such as the backward Euler method, contain algebraic formulas that need to be solved. The Euler, Runge-Kutta, and Adams 
methods are all explicit algorithms. 

Stiff vs. nonstiff 

Stiffness refers to that property of a system in which the time step required to maintain stability for an explicit method is much smaller than the time step 
required to achieve a desired level of accuracy. The critical value hc depends on the fastest settling rate of the dynamics of the system of ODEs. 

You may get a good approximation with the Euler method using a time step h=0.01, but the solution may be unstable using a time step h=0.11. Such 
instability is typical of explicit algorithms, which are said to be conditionally stable. The solution is stable if the constant time step h is sufficiently small. 
The solution becomes unstable if the constant time step is larger than the critical value hc. Varying time step algorithms avoid such instability by staying 
below hc.  

Low order vs. High order 

All algorithms in computing their approximation use a finite number of values of the function f. Truncation error emanates from this approximation. The 
maximum truncation error, for constant time step algorithms, when solving a differential equation over a fixed time interval t0<=t<=T is proportional to the 
time step h raised to some exponent p, the order of the method.  

The forward and backward Euler Methods both have an order 1, the classic Runge-Kutta method has order 4, and the Adams method with k memory 
levels has order k. Usually a high order method is more efficient than a low order method, however there are exceptions and there are conditions when 
using a high order method is not beneficial. 

Accuracy Tolerance 

The speed and accuracy of your numerical solution will vary according to the accuracy tolerance you specify, being the relative error and absolute error. 
Error tolerances should neither be too large or too small. A relative accuracy should be specified as at least 1%. You can get incorrect error estimates 
from the algorithms error estimation formulas if the error tolerance is too large. This in turn will affect the adaptive time step size control and the solution 
will not have the accuracy specified. 

Likewise if the tolerance is too small, the computation time will be unduly long or even impossible. The latter refers to computer round off errors. Thus, 
sometimes it is better to use less stringent error tolerances. 

Euler's Method 

Euler's method is the simplest solution algorithm for ODE initial condition problems, often used for comparison with more accurate algorithms. It uses an 
initial condition, a point in a plane, and an ordinary differential equation that describes how the function moves from the point. You can then get 
approximate values of the function at later time points. Euler's method uses a tangent line method of approximation. At each point, the function is 
approximated by its tangent line at that point, traversed some small interval of time, and then repeated. 

Table of Contents

8. Accessing Simulation Results  
Results from simulations are automatically stored on the remote database server. The results may be reviewed immediately by pressing the Results 
button on the Simulation panel of the Application dialog. The Results button becomes active once results are available. 

 

8.1 Compartmental Results 
Results generated from a compartmental simulation are displayed as a graph or alternatively you can display the values. 
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View Data 
Plot/Values Display 

Display your results as a plot or display the data values. Select a single cell or multiple 
cells. Use ctrl C to copy individual cells and ctrl K to copy all the cells into a spreadsheet. 
Alternatively, hold down the right mouse button to access a menu with Copy and Copy All options. 

 
X and Y Axes  

Select a variable for each axis; the graph will update accordingly. A different line color is displayed 
for each variable. Use the up and down arrow keys on your keyboard to step through the list of 
variables; the graph will update with each variable change. You can select more than one variable 
by using the Shift key for sequential variables or by using the Ctrl key for random variables. 

Time Series Plot   
The Time Series plot is specified by selecting the independent variable t, in the X axis choice 
box, and a dependent variable in the Y axis choice box. 

Phase Plane Plots   
You can select Phase Plane plots by selecting the two dependent variables in the choice 
boxes. 

Add Function   
Press to define a Function that can be displayed in the graph under the Y axis. Use Delete 
Function to remove the function. 

Plot Settings  
The graph is interactive. Move your cursor over the graph, a crosshair will appear and the 
corresponding X and Y coordinate values will be displayed in the bottom left corner of the 
dialog. Press your right mouse button to access advanced options. 

Axis Scale – Select either auto scale mode or deselect for manual scale model. When in 
manual mode you must supply min and max graph values. 
 Auto Scale – Computer will calculate best values for displaying graph.  
 Stretch - In auto mode, use to stretch graph for better viewing. 
Plots – Plot display options. 
 Draw nodes - Select to draw a node at each data point. 
 Show crosshair - Enable the crosshair to be displayed when you move your mouse over the graph. 
 Snap to nodes - Select to have crosshair snap to nodes, deselect to move crosshair freely across 
the graph. 

Plot Sensitivity   
Select this option to see the Sensitivity results that were calculated as you ran the simulation. (Note 
you had to choose Sensitivity Analysis prior to running your simulation.) Choose a variable from the 
selection list to plot. Use the scroll bar to alter the parameter value and the graph will update without 
rerunning the solver. Please note that the solutions for altered parameter values are approximate since 
the sensitivity analysis is based on the nominal value. Thus, the farther away from the nominal value 
the less accurate a solution is. However, the results may still be interpreted qualitatively. If the user 
requires an accurate solution based on the qualitative data, it is recommended to rerun the simulation 
with the appropriate parameter(s) changed. Click on Log Sensitivity to display the normalized (log) sensitivities as a function of time. 

Export Data   
Export feature for data. See chapter 9 for more information.   

8.2 Spatial Results 
The image data from spatial simulations are displayed in the results dialog. You can also generate 
a Spatial Plot, using defined regions, a Time Plot, using points, or a Kymograph, which displays a 
line scan over time. In addition you can copy and paste the data values from the graph directly into 
a spreadsheet. 

View Data 
Time   

The data time point that is displayed. Enter a value in the 
text field or click once on the selection arrow. Use the up 
and down arrow keys on your keyboard to select a time 
point. The image will update when the time point is 
changed. 

 
Add/Delete Function 

You have the capability to create functions using the 
existing variables. Press the Add Function button to access the function dialog 
and use the default Function name or create a new one. Type in your expression in the Function Expression text field and press OK to 
accept your entries. The Delete Function will become active once a function has been created. Simply select the function you wish to 
delete and the press the Delete Function button. 

 
Auto Range  

 Select to have the software automatically adjust the image display pixel intensities based on the minimum and maximum data values for 
the selected time point. The intensities are automatically converted to and displayed as concentrations. 

Min/Max   

 22



Deselect Auto Range and type in the value(s) for the minimum and/or maximum; press enter to accept the values and to update the 
image display. 

Color   Color Value  Definition 
M  Below minimum color 
AM  Above minimum color 
NN  Not a number color 
IL  Illegal value color 
NR  No range color 

View the image data either in Grayscale or in a Blue-Red color map 
where colors are mapped according to concentration. At times some 
values will be displayed in colors other than the selected color map 
because they do not fall within the specified range. 

 
 

Variable   
Select which variable's data you wish to display. 
 Add Function 

Selection/Drawing Tools  

  Choose from selection arrow, point, line, spline or add an additional control point. The line and points are gray when 
deselected; control nodes and points are white when selected. 

 Deleting Points, Lines, or Curves - Use the selection tool to select the item and then use either Backspace or the Delete key to delete 
it. 

Image Zoom  

  Use the image zoom feature to ease in the selection of lines and/or points. Select the 
Magnification icon and press your left mouse button while you move the mouse across the image 
to increase and decrease the image zoom. Alternatively you can press the alt key and drag the 
mouse across the image to zoom up or down. 

Pan Tool   

 Use the pan tool, while the image is zoomed up, to move across the image. With the Hand 
icon depressed, hold down the left mouse button and drag the mouse across the image to move it. 

 
Slice   

View 3-D data sets by using the Plus (+1/10) and Minus (-1/10) buttons to step through the series. 
 

Axis   
The Axis is provided as an additional means of viewing your 3-D image data. 

 
 
Spatial plot   

This will become active once you use the line or spline tools to define a region. Select the region and then press Spatial plot to display 
the graph for that area. The graph is interactive; as you move the mouse over the graph, the coordinates are displayed in the bottom 
left corner. 

 
 
 
 
 
 
 
 
 
 
 
Time Plot   

This will become active when you use the point tool to define a point or series of points. Press Time plot to view the graph of the 
selected point(s). 
 
 
 
 
 

 

. 

 
 
 
 
 
 

Single point Time plot. 

 
Plot/Values Display 

Display your results a
into a tab-delimited sp
copy individual cells a
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Plot Settings   
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 Auto Scale - Select for auto scale mode or deselect for manual scale model. When in manual mode, enter min and max graph. 
 Stretch - In auto mode, use to stretch graph for better viewing. 
 Draw nodes - Select to draw a node at each data point. 
 Show crosshair - Select to enable the crosshair so it is displayed when you move your mouse over the graph. 
 Snap to nodes - Select to have crosshair snap to nodes, deselect to move crosshair freely across the graph. 

 
 
Kymograph 

The kymograph tab, which displays line scans over time, will become active on the results panel once a line is drawn over the image 
data.  The kymograph dialog displays the data in a visual image format where 
the distance of the line is plotted against time as well as in a multiple graph 
format. Two graphs display the concentration of the selected variable plotted 
over distance and over time. These plots will update according to the position 
of the crosshair, which is created with the mouse, in the image data panel. In 
addition, each graph has a mouse menu feature for additional plot settings, 
see above. 

 Variable – Select data variable. 
 Zoom Out/Zoom In – Select either button to change zoom display of image 
data. 

 Copy all – Use this function to paste data into a program other than the 
Virtual Cell. 

 Image Data Mouse Menu – Use the right mouse button,  over the image data to access the following options: Copy All, Copy Time 
Series, Copy Line Scan, Scale Image to All Data, Scale Image to Line Scan, and Scale Image to Time Series. The copy functions are 
for pasting data into a program other than the Virtual Cell. The scale functions are for changing the scale of the image data display. 

Export Data   
Export feature for data. See chapter 9 for more information.   

8.3 3D Membrane Surface Viewer 
The 3D Membrane Surface Viewer allows users to view, manipulate and pick values from their 3D 
spatial simulation membrane data interactively.  The 3D Membrane Surface Viewer allows views of 
the data from any viewpoint and the view can be changed easily using the mouse. Hints for all the 
keyboard and mouse controls are provided beneath the surface display. 

The Membrane Surface Viewer is activated by pressing the "Show Membrane Surfaces" button at 
the bottom of the Simulation Results Viewer. Note this button is visible and only active with a 3D 
data set, and this button is only active when a membrane variable has been chosen from the list 
of variable names on the left of the Simulation Results Viewer.  The Membrane Surface Viewer will 
be initialized with the color scaling and data values for the current variable name and time point 
chosen in the Simulation Results Viewer.  When the Membrane Surface Viewer has been 
activated, the "Show Membrane Surfaces" button text will change to "Update Membrane Surfaces".  
This button may be pressed at any time to synchronize the Membrane Surface Viewer display 
parameters with the current Simulation Results Viewer display parameters.  Variable, time and 
color scaling selections in the Simulation Results Viewer will not be synchronized in the Membrane 
Surface Viewer unless the "Update Membrane Surfaces" button is pressed.  When the Membrane 
Surface Viewer is closed (click on X in upper right corner) the window will disappear but the current 
view and pick info settings will not be lost. 

Name   
Name refers to the list of all the contiguous membrane surfaces relating to the 
boundary between any two volume regions. 

Size   
Size for surfaces are described in square microns. 

Visible  
Independently turn on and off the viewing of surfaces to allow for viewing interior 
surfaces that would otherwise be obscured. 

Wire frame   
Produce an outline of each patch of membrane existing between simulation mesh 
volume elements. The resulting outline is only a gross approximation of the actual 
computational surface used to generate the simulation data. 

Transparent 
Choose between none, 25%, 50% and 75%. None will show the solid surface while transparency will be enabled by selecting one of the 
percentages. Transparency enabled in a higher level surface enables you to view any underlying surfaces.  The higher the percentage, the 
more any underlying surfaces will show through on the display. 
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Rotate (Left Mouse Button (leftMB)) 
The view may be rotated arbitrarily using a "trackball" interface provided by dragging the mouse with the left mouse button (leftMB) pressed.  
The view rotates as if the mouse were attached to a sphere containing the surfaces.  Depending on where the leftMB is first pressed and 
the direction of drag, the user may move the view to any perspective.   
Move (Right mouse button (rightMB)) 

The view may also be moved side to side and up or down by dragging the mouse with the right mouse button (rightMB) pressed.  

Zoom ( Left and right mouse buttons (leftMB-rightMB)) 
The view can also be zoomed in or out by dragging the mouse with the left and right mouse buttons (leftMB-rightMB) pressed.   

Info (Left Mouse Button (leftMB) and Control key (Ctrl)) 
The mouse can also be used to retrieve the data value and centroid coordinate for the simulation at a particular membrane location by 
holding down the control key on the keyboard while clicking the leftMB.  The data value and centroid coordinate for the corresponding 
membrane patch will be displayed in red directly beneath the display area for the surfaces.   

Home   
A preset "HOME" view (button in the window upper left) is provided allowing users to reset their view to a common perspective.  

Bounding box   
Checkbox in the upper left corner of the window can be turned on and off to show where membranes surfaces are located with respect to 
the entire simulation data volume. 
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9. Exporting Simulation Results  
Results from simulations are automatically stored on the remote database server. Simulation results may be exported immediately after the simulation or 
at your leisure by using the Export option located on the bottom of the Results dialog.  

9.1 Compartmental Results 

Time Interval   
Select a single time point or a range of time for the selected variable(s).  

Variables  
Select a single variable (species), a selected list of variables, or all the variables. Only data pertaining 
to your selected variables will be exported. 

 Multiple Variables   
To select more than one variable, select one variable and then hold down the Shift key to select additional variables. To select the 
entire list of variables, select the first variable in the list and then hold down the Shift key and select the last variable in the list. 

Export Format  
Compartmental data is limited to Comma delimited ASCII files (.csv files). 
Comma delimited ASCII files are used for organizing data in a spreadsheet 
format. 

Select Data Type to Export   
 Choose between Variable values and Particle data. (Please note the 
latter is not yet implemented.) 

 Additional Formatting  - You can switch the orientation of the rows 
and columns. Some spreadsheet programs limit the number of 
columns to 256 columns. If your data should exceed this, you may 
opt to switch the rows and columns so the program will still read the data. 

Start Export   
Once you have made your Time and Variable selections press Start Export to initiate the file export. Choose the appropriate ASCII Settings 
and press OK. Netscape and Internet Explorer browsers will handle the export process in the same manner.  Once the export process is 
complete, a Save dialog will appear.  Navigate to an area on your local drive to store the .zip file.  

 

Export Monitor  
The Export Monitor displays job ID, file Format, Progress bar, Completed/Not Completed status, File Location and Simulation ID. 

9.2 Spatial Results 
When you choose to export data, use the Drawing tools, point, line or spline, to define the region(s) or point(s) you are interested in on the View Data 
tab. Once you have drawn the region on the image, select it once using the selection tool and go to the Export Data tab and press Add. The selected 
point or curve will be defined in the Region text field. 
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Time Interval   
Select a single time point or a range of time for the selected variable(s). A range 
must be selected for movie files whereas a single time point may be used for .csv 
files and individual image files. Type a value in the text field and/ or use the slider 
on the time line. Click once on the selector. Use the left and right or up and down 
arrow keys on your keyboard to select the time point. 

Variables   
Select a single variable (species), a selected list of variables, or all the variables. 
Only data pertaining to the selected variables will be exported. 

 Multiple Variables   
To select more than one variable, select one variable and then hold down 
the Shift key to select additional variables. To select the entire list of 
variables, select the first variable in the list and then hold down the Shift 
key and select the last variable in the list. 

Region   
You can select your data as points, a line, or a slice if the data set is 3-dimensional; choose either Selection or Slice. 

Add   
Select the variable(s) you are interested in and press Add to define the point, line or curve in the text field. 

Remove   
Select a defined curve or point and press Remove to delete it from the export list. Note that deleting the curve or point from this list does not 
remove the drawing from the image displayed above.  

Slice   
Select Slice for 3-D data sets. Only the data for the slice selected will be exported. 
Choose the Z slice in the Results dialog using the +/- 1/10 increment buttons and the 
Axis using the XY, YZ or ZX radio buttons. The slice option is required for exporting 3-D 
data as QuickTime movie files and animated GIF files. 

Start Export   
Press to initiate your export once you have made your Time, Variable, Region and Export Format selections. Netscape and Internet 
Explorer browsers will handle the export process in the same manner. Once the export process is complete, a Save dialog will appear. 
Navigate to an area on your local drive to store the .zip file.  

Export Monitor   
The Export Monitor displays job ID, file Format, Progress bar, Completed/Not Completed status, File Location and Simulation ID. 

Export Format  
Once you have selected your Time Interval, Variable(s), and Region, select the type of file you wish to export your data as and then press Start Export. 
Data may be exported as Comma Delimited ASCII files, Quick Time movie files, GIF89a image files, or animated GIF files. 

Comma Delimited ASCII Files   
Comma delimited ASCII files are used for organizing data in a 
spreadsheet format. 

Select Data Type to Export   
 Choose between Variable values and Particle data. Please note the 
latter is not yet implemented. 

Additional Formatting   
 You can switch the orientation of the rows and columns. Some 
spreadsheet programs limit the number of columns to 256 columns. If your data should exceed this, you 
may opt to switch the rows and columns so the program will still read the data. 

Quick Time Movies   
Remember to select Range under the Time Interval for exporting a Quick Time movie. Preview the files you wish to export 
using the Manual Scale in Simulation Data. You must use the Manual Scale to export a movie so choose settings that are 
suitable for all the time points. Auto Scale does not work because the movie cannot readjust the display for each frame. 

Select data format   
Choose between uncompressed 32 bit RGB files or Compressed 

Movie duration   
Enter a time, in seconds, and then press Set.  

Select composition mode   
If you have multiple variables, you may select from two options. 

One movie for each variable   
Each variable is displayed in its own movie. 
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Overlay variables (single movie)   
Export a single movie displaying each variable. The variables are still seen separately but contained in one Quick Time display.  

Hide Membrane Outline   
Display option for membrane. 

 
Extend images by mirroring  

You can extend the image size for symmetric data sets by selecting the mirroring option. 
 

GIF Image Files   
GIF image files can be generated from either a single time point or from a range of time points and from one or more 
variables. One image file will be exported for each data point, for each variable. (TIFF and JPEG file options will be 
offered in the future.)  

Loop infinitely  
Select loop option. 

Compression mode  
Forced Compression (indexed 256 colors). 

Hide Membrane Outlines   
Display option for membrane. 

Extend images by mirroring  
Select the Mirroring option to extend the image size of symmetric data sets. 

 

Animated GIF Files   
Animated GIF files can be generated from a selected range of time points. 

Loop infinitely   
Select loop option. 

Compression mode   
Forced compression (indexed 256 colors). 

Hide Membranes Outlines   
Display option for membrane. 

Extend images by mirroring   
Select the Mirroring option to extend the image size of symmetric data sets. 
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10. Creating Math Model Documents 
The Virtual Cell Math Description Language, VCMDL, is a declarative mathematics language that has been developed to concisely describe the class of 
mathematical systems that are encountered in the Virtual Cell project.  This language defines parameters, independent variables, differential/algebraic 
systems defined over a complex geometry including discontinuous solutions and membrane boundaries and the description of the task to perform on 
such a system. A formal definition of the language has been provided for your reference in a BNF grammar. 

You may choose to create a Math Description manually using VCMDL in the Virtual Cell Math Editor or you 
may first create a BioModel and then import that description into the Math model. 

Each Math document consists of the VCML Editor, The Equations Viewer, the Geometry Viewer, and 
Simulations. 

10.1 Creating New Math Models 
If you choose to create a new math description, go to File>New>MathModel> and select either Non-Spatial 
or Spatial. If you choose a Spatial Math Model you will be prompted to select a Geometry document from the 
database. The Math document will initialize with the Math Editor. The compartmental model will include a 
single subDomain Compartment whereas the spatial model will contain the subDomains as described in the 
Geometry that you selected. 

VCML Editor   
You can type in your Math Description in the text field.  There is a message panel at the bottom of the editor 
that displays warnings and/or error messages. Use the Apply Changes and Cancel buttons to invoke your 
changes. You can use the functions ctrl C -copy, ctrl V -paste, and ctrl X -cut for editing purposes. 

Apply Changes   
Press to implement your changes. 

Cancel   
Use to undo your editing. Cancel cannot be used once you have used Apply Changes. 
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Equation Viewer   

This panel is a summary of the math description broken down into constants, functions, volume domains 
and membrane domains, or whatever is applicable to your model. The Equation Viewer is for viewing 
purposes only; you cannot edit the equations there. All edits are performed in the VCML editor. 

Geometry Viewer 
The Geometry Viewer displays the current Geometry associated with either the spatial or non-spatial 
math document.  

Change Geometry 
Press to access the Geometry database for changing the current math document geometry. 

View Surface 
View geometry surfaces. 

Simulations 
This opens the Simulations dialog for running simulations within the context of the math 
document. Please see information regarding simulations in Chapter 7. You will be able to run 
simulations only once you have a valid VCML math description. 

10.2 Creating Math Models from BioModels 
You must first have an Application associated with a BioModel in order to generate a math 
model because it relies on the math description generated by the software. The Application 
establishes the relationship between the BioModel description and the Geometry, and the 
math description is generated once an Application is created.  The Math Description will be 
created once you save the BioModel and associated Applicaiton or you generate the math 
manually via the Application dialog.  

To open your model, go to File>New>MathModel >from BioModel and select your model from the BioModel database. Select an Application from that 
BioModel; the model will be opened with the context of the Math document. 
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